aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-26 10:51:54 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-27 10:09:10 +0200
commit0a97b172e5a5d85c06b7f62fc7c5594a99b79b64 (patch)
tree6ff029bc283225eeefed11995a6eb3722e6dbcf4 /gnu/packages/tryton.scm
parent261b5cced5a6bfbf30cdaa234d3cc6a2dc864fb9 (diff)
downloadguix-0a97b172e5a5d85c06b7f62fc7c5594a99b79b64.tar
guix-0a97b172e5a5d85c06b7f62fc7c5594a99b79b64.tar.gz
gnu: Add python-trytond-stock-supply.
* gnu/packages/tryton.scm (python-trytond-stock-supply): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index ae6de75ced..3809b986d5 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -734,6 +734,62 @@ lines and stock moves. The unit price of the stock move is updated with the
average price of the posted invoice lines that are linked to it.")
(license license:gpl3+)))
+(define-public python-trytond-stock-supply
+ (package
+ (name "python-trytond-stock-supply")
+ (version "5.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_stock_supply" version))
+ (sha256
+ (base32 "0lw7qrg58k5pjpp3nz73rmlm8v086l49ri31ci75calm552zpfay"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (let ((runtest
+ (string-append
+ (assoc-ref %build-inputs "python-trytond")
+ "/lib/python"
+ ,(version-major+minor (package-version python))
+ "/site-packages/trytond/tests/run-tests.py")))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" runtest "-m" "stock_supply")))))))
+ (native-inputs
+ `(("python" ,python-minimal-wrapper)
+ ("python-dateutil" ,python-dateutil)
+ ("python-genshi" ,python-genshi)
+ ("python-lxml" ,python-lxml)
+ ("python-magic" ,python-magic)
+ ("python-passlib" ,python-passlib)
+ ("python-polib" ,python-polib)
+ ("python-proteus" ,python-proteus)
+ ("python-relatorio" ,python-relatorio)
+ ("python-werkzeug" ,python-werkzeug)
+ ("python-wrapt" ,python-wrapt)))
+ (propagated-inputs
+ `(("python-sql" ,python-sql)
+ ("python-trytond" ,python-trytond)
+ ("python-trytond-account"
+ ,python-trytond-account)
+ ("python-trytond-party" ,python-trytond-party)
+ ("python-trytond-product"
+ ,python-trytond-product)
+ ("python-trytond-purchase"
+ ,python-trytond-purchase)
+ ("python-trytond-purchase-request"
+ ,python-trytond-purchase-request)
+ ("python-trytond-stock" ,python-trytond-stock)))
+ (home-page "https://www.tryton.org/")
+ (synopsis "Tryton module for stock supply")
+ (description
+ "This package provides a Tryton module that adds automatic supply
+mechanisms and introduces the concepts of order point.")
+ (license license:gpl3+)))
+
(define-public python-trytond-purchase
(package
(name "python-trytond-purchase")