aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-04-07 08:49:43 -0500
committerEric Bavier <bavier@member.fsf.org>2017-04-08 22:20:06 -0500
commitf3cf25c3c2aef91a47b790fe69b5008cdb6a6316 (patch)
tree6354211cdcfc21828b9addae0e106c1ca531a60c /gnu/packages/tor.scm
parenta3c57693e42ff9bba088af50b7472d981e6ac387 (diff)
downloadguix-f3cf25c3c2aef91a47b790fe69b5008cdb6a6316.tar
guix-f3cf25c3c2aef91a47b790fe69b5008cdb6a6316.tar.gz
gnu: torsocks: Patch references to 'getcap' and 'which'.
* gnu/packages/tor.scm (torsocks)[inputs,arguments]: New fields.
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index e48017e640..06b6c4febc 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,7 +29,9 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages)
+ #:use-module (gnu packages base)
#:use-module (gnu packages libevent)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages compression)
#:use-module (gnu packages pcre)
#:use-module (gnu packages python)
@@ -88,6 +91,19 @@ the application layer) you need to install @code{torsocks}.")
(base32
"0byr9ga9w79qz4vp0m11sbmspad7fsal9wm67r4znzb7zb7cis19"))))
(build-system gnu-build-system)
+ (inputs
+ `(("which" ,which)
+ ("libcap" ,libcap)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'build 'absolutize
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/bin/torsocks"
+ (("getcap=`.*`")
+ (string-append "getcap=" (which "getcap")))
+ (("`which")
+ (string-append "`" (which "which"))))
+ #t)))))
(home-page "https://www.torproject.org/")
(synopsis "Use socks-friendly applications with Tor")
(description