aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-16 20:23:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-04-17 04:02:09 +0200
commitc80590f646f47d4199a8452ee9f3fb4271f72803 (patch)
tree134b35c25f95b739d665a9172f4d894146e7c96f /gnu/packages/tls.scm
parent7f1d8b5cdb67b7062a6c8b12558a05b8735588aa (diff)
downloadguix-c80590f646f47d4199a8452ee9f3fb4271f72803.tar
guix-c80590f646f47d4199a8452ee9f3fb4271f72803.tar.gz
gnu: Add perl-crypt-openssl-guess.
* gnu/packages/tls.scm (perl-crypt-openssl-guess): New public variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 60e29bfe82..6ab5cfbc54 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
@@ -736,6 +736,28 @@ arithmetic in Perl.")
;; At your option either gpl1+ or the Artistic License
(license license:perl-license)))
+(define-public perl-crypt-openssl-guess
+ (package
+ (name "perl-crypt-openssl-guess")
+ (version "0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/A/AK/AKIYM/Crypt-OpenSSL-Guess-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0rvi9l4ljcbhwwvspq019nfq2h2v746dk355h2nwnlmqikiihsxa"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Crypt-OpenSSL-Guess/")
+ (synopsis "Guess the OpenSSL include path")
+ (description
+ "The Crypt::OpenSSL::Guess Perl module provides helpers to guess the
+correct OpenSSL include path. It is intended for use in your
+@file{Makefile.PL}.")
+ (license license:perl-license)))
+
(define-public perl-crypt-openssl-random
(package
(name "perl-crypt-openssl-random")