aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-11-05 19:12:36 -0500
committerLeo Famulari <leo@famulari.name>2017-11-06 13:44:16 -0500
commita7c7d5ab8bf2a5e7c21c401cb93ffa0164eccbbb (patch)
tree01af68fa1b67bbc071427e8f80279cd3173306f2 /gnu/packages/tls.scm
parentb5f610620b65eabd671a5f68d6e6155194101efa (diff)
downloadguix-a7c7d5ab8bf2a5e7c21c401cb93ffa0164eccbbb.tar
guix-a7c7d5ab8bf2a5e7c21c401cb93ffa0164eccbbb.tar.gz
gnu: gnutls: Don't allow the built GnuTLS to refer to net-tools-for-tests.
* gnu/packages/tls.scm (gnutls)[arguments]: Add net-tools-for-tests to #:disallowed-references.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 60fb14c9ae..9eba717e60 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -133,9 +133,6 @@ coordinating the use of PKCS#11 by different components or libraries
living in the same process.")
(license license:bsd-3)))
-
-;; TODO Add net-tools-for-tests to #:disallowed-references when we can afford
-;; rebuild GnuTLS (i.e. core-updates).
(define-public gnutls
(package
(name "gnutls")
@@ -156,7 +153,8 @@ living in the same process.")
"15ihq6p0hnnhs8cnjrkj40dmlcaa1jjg8xg0g2ydbnlqs454ixbr"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags
+ '(#:disallowed-references ,(net-tools-for-tests)
+ #:configure-flags
(list
;; GnuTLS doesn't consult any environment variables to specify
;; the location of the system-wide trust store. Instead it has a