aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-19 01:44:30 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-19 01:44:30 +0100
commit4a158286a683d5f599b829f797fc5e8e997af06d (patch)
tree4a97a64913f83842505d508eb693e2bfa92fab6b /gnu/packages/tls.scm
parent32cd878be0bb7e153fcaa6f3bfa2632867390ff9 (diff)
downloadguix-4a158286a683d5f599b829f797fc5e8e997af06d.tar
guix-4a158286a683d5f599b829f797fc5e8e997af06d.tar.gz
gnu: openssl: Remove graft for 1.0.2n.
* gnu/packages/tls.scm (openssl): Update to 1.0.2n. (openssl-1.0.2n): Remove variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm24
1 files changed, 2 insertions, 22 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 8eff723543..64ee404417 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -246,8 +246,7 @@ required structures.")
(define-public openssl
(package
(name "openssl")
- (version "1.0.2m")
- (replacement openssl-1.0.2n)
+ (version "1.0.2n")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -259,7 +258,7 @@ required structures.")
"/" name "-" version ".tar.gz")))
(sha256
(base32
- "03vvlfnxx4lhxc83ikfdl6jqph4h52y7lb7li03va6dkqrgg2vwc"))
+ "1zm82pyq5a9jm10q6iv7d3dih3xwjds4x30fqph3k317byvsn2rp"))
(snippet
'(begin
;; Remove ELF files. 'substitute*' can't read them.
@@ -391,25 +390,6 @@ required structures.")
(license license:openssl)
(home-page "http://www.openssl.org/")))
-;; Fixes CVE-2017-3735, CVE-2017-3736, CVE-2017-3737, and CVE-2017-3738.
-;; See <https://www.openssl.org/news/cl102.txt>.
-(define-public openssl-1.0.2n
- (package
- (inherit openssl)
- (version "1.0.2n")
- (source (origin
- (inherit (package-source openssl))
- (uri (list (string-append "https://www.openssl.org/source/openssl-"
- version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/openssl-"
- version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/old/"
- (string-trim-right version char-set:letter)
- "/openssl-" version ".tar.gz")))
- (sha256
- (base32
- "1zm82pyq5a9jm10q6iv7d3dih3xwjds4x30fqph3k317byvsn2rp"))))))
-
(define-public openssl-next
(package
(inherit openssl)