aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-02-26 14:47:15 -0500
committerKei Kebreau <kkebreau@posteo.net>2018-02-27 10:33:59 -0500
commit36d48a536e0bd86f1fdb7f41038db4aa4e0507cb (patch)
tree83371164182d6a992f986b6f72fd56e3306e274c /gnu/packages/tls.scm
parent0fb405796cdb5579c911b30da9d40b4a18cd7f07 (diff)
downloadguix-36d48a536e0bd86f1fdb7f41038db4aa4e0507cb.tar
guix-36d48a536e0bd86f1fdb7f41038db4aa4e0507cb.tar.gz
gnu: mbedtls-apache: Fix upstream typo.
A typo was introduced in version 2.7.0 that caused the hiawatha package to fail to build. See https://github.com/ARMmbed/mbedtls/pull/1362. * gnu/packages/tls.scm (mbedtls-apache)[source]: Add snippet to fix typo.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 9e06e675f4..2233b5974c 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -797,7 +797,15 @@ then ported to the GNU / Linux environment.")
version "-apache.tgz"))
(sha256
(base32
- "1vsmgxnw7dpvma51896n63yaf9sncmf885ax2jfcg89ssin6vdmf"))))
+ "1vsmgxnw7dpvma51896n63yaf9sncmf885ax2jfcg89ssin6vdmf"))
+ ;; An RFC 5114 constant was accidentally renamed in version 2.7.0.
+ ;; See https://github.com/ARMmbed/mbedtls/pull/1362.
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "include/mbedtls/dhm.h"
+ (("#define MBEDTLS_DHM_RFC5114_MODP_P")
+ "#define MBEDTLS_DHM_RFC5114_MODP_2048_P"))))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags