aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-06-08 15:25:30 -0400
committerLeo Famulari <leo@famulari.name>2017-06-08 15:53:49 -0400
commit6175937011bc7891006468ea700f90d3335e6886 (patch)
tree77da06f22534dc95b1bad0f9945aede83adb16f5 /gnu/packages/tls.scm
parent1e0ae3b352d4521aa2a88158ab49277cea7cd0bd (diff)
downloadguix-6175937011bc7891006468ea700f90d3335e6886.tar
guix-6175937011bc7891006468ea700f90d3335e6886.tar.gz
gnu: certbot, python-acme: Update to 0.15.0.
* gnu/packages/tls.scm (certbot, python-acme, python2-acme): Update to 0.15.0. (python-acme, python2-acme)[arguments]: Remove 'patch-dependency' phase. This issue was fixed upstream: https://github.com/certbot/certbot/commit/d0e471dc8093bd0d08c5a739e5cf9677240d9c0e
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 7f62b37690..cdb4becb07 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -484,25 +484,17 @@ security, and applying best practice development processes.")
(package
(name "python-acme")
;; Remember to update the hash of certbot when updating python-acme.
- (version "0.14.2")
+ (version "0.15.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "acme" version))
(sha256
(base32
- "1kbgpjabbly7r757vyr1050ixnm9hyvrbf9n6aq49cgmb147ysqn"))))
+ "11zwgj663vr575pbqw74ia10wxaw16i8rnkcivsrbsx148rxdbcz"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-dependency
- ;; This module is part of the Python standard library, so we don't
- ;; need to use an external package.
- ;; https://github.com/certbot/certbot/pull/2249
- (lambda _
- (substitute* "setup.py"
- (("'argparse',") ""))
- #t))
(add-after 'build 'build-documentation
(lambda _
(zero? (system* "make" "-C" "docs" "man" "info"))))
@@ -549,7 +541,7 @@ security, and applying best practice development processes.")
(uri (pypi-uri name version))
(sha256
(base32
- "1b39hybswzm8mkarg1mwpx47wffqg57jcgi52mz5iz60rxym9j2v"))))
+ "1srvmjxz75dbafx7xfg1w3n9h3srr9p2ljnfsih9dwwd5cxh9i5q"))))
(build-system python-build-system)
(arguments
`(#:python ,python-2