aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-17 23:24:42 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-17 23:43:14 +0100
commit3a317f7476f8c6012e166ff9f340f861938721c9 (patch)
tree946e398c37912cfc03be7306951ae87bfeb130fa /gnu/packages/tls.scm
parente55547bf70384691712047912c793c517debd2ec (diff)
parent62e707d67caf1dab2af411a69ff8cec4b2dc686e (diff)
downloadguix-3a317f7476f8c6012e166ff9f340f861938721c9.tar
guix-3a317f7476f8c6012e166ff9f340f861938721c9.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm62
1 files changed, 29 insertions, 33 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index be8f7a4a12..a93621fa93 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -351,9 +351,6 @@ required structures.")
,@(alist-delete "guile"
(package-inputs gnutls))))))
-(define-public guile3.0-gnutls
- (deprecated-package "guile3.0-gnutls" gnutls))
-
(define (target->openssl-target target)
"Return the value to set CONFIGURE_TARGET_ARCH to when cross-compiling
OpenSSL for TARGET."
@@ -662,13 +659,13 @@ netcat implementation that supports TLS.")
(package
(name "python-acme")
;; Remember to update the hash of certbot when updating python-acme.
- (version "1.17.0")
+ (version "1.18.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "acme" version))
(sha256
(base32
- "03ij1wp7jwvppv70qbjkgdg7w824yh6j4gfb68jj20wicx08xx1a"))))
+ "1bv2swaqmzpcx2nq1nbhrc6b825d5sxkdv0al972sjfcpcqn1q4s"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -716,7 +713,7 @@ netcat implementation that supports TLS.")
(uri (pypi-uri "certbot" version))
(sha256
(base32
- "0wyipx6q78fmvngf1i6g50s01qpjqh07qlk1b5vyxwgl3080lhgg"))))
+ "0yr8sxfg5zspal04l9lpd9xis6gp8il20bhka54xr9bb4hc6xrgk"))))
(build-system python-build-system)
(arguments
`(,@(substitute-keyword-arguments (package-arguments python-acme)
@@ -1142,39 +1139,38 @@ derived from Mozilla's collection.")
(license license:mpl2.0))))
(define-public s2n
- (let* ((commit "7f43b102def1d52422f6c3e48d5cb3e6dd26c646")
- (revision "1"))
- (package
- (name "s2n")
- (version (git-version "1.0.10" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/aws/s2n-tls")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "06rqg0vcispi63cmcza9j7ix80l0w6wmbw81qlg4fq8l1lg9nyvl"))))
- (build-system cmake-build-system)
- (arguments
- '(#:configure-flags
- '("-DBUILD_SHARED_LIBS=ON")))
- (propagated-inputs
- `(("openssl" ,openssl)
- ("openssl:static" ,openssl "static")))
- (synopsis "SSL/TLS implementation in C99")
- (description
- "This library provides a C99 implementation of SSL/TLS. It is designed
-to be familiar to users of the widely-used POSIX I/O APIs. It supports
-blocking, non-blocking, and full-duplex I/O. There are no locks or mutexes.
+ (package
+ (name "s2n")
+ ; Update only when updating aws-crt-cpp.
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/s2n-tls")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14dhdddlph36nshdkh0v33718hxjx5vxqxmkw7707393q0qrgipw"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (propagated-inputs
+ `(("openssl" ,openssl)
+ ("openssl:static" ,openssl "static")))
+ (synopsis "SSL/TLS implementation in C99")
+ (description
+ "This library provides a C99 implementation of SSL/TLS. It is designed to
+be familiar to users of the widely-used POSIX I/O APIs. It supports blocking,
+non-blocking, and full-duplex I/O. There are no locks or mutexes.
As it can be difficult to keep track of which encryption algorithms and
protocols are best to use, s2n-tls features a simple API to use the latest
default set of preferences. Remaining on a specific version for backwards
compatibility is also supported.")
(home-page "https://github.com/aws/s2n-tls")
- (license license:asl2.0))))
+ (license license:asl2.0)))
(define-public wolfssl
(package