aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-09-29 22:10:33 +1000
committerLudovic Courtès <ludo@gnu.org>2015-10-01 10:36:11 +0200
commitaae2b445a4c13649d2711e9ee1f17fae72bdea19 (patch)
tree4d333b4c23057e4335cb297869a6f2964215960b /gnu/packages/textutils.scm
parentb73547e17994d09411278f482621f7866754b76d (diff)
downloadguix-aae2b445a4c13649d2711e9ee1f17fae72bdea19.tar
guix-aae2b445a4c13649d2711e9ee1f17fae72bdea19.tar.gz
gnu: Add cityhash.
* gnu/packages/textutils.scm (cityhash): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 95a8ad1da9..9f7cdddcad 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Ben Woodcroft <donttrustben@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -153,3 +154,26 @@ encoding, supporting Unicode version 7.0.")
"libgtextutils is a text utilities library used by the fastx toolkit from
the Hannon Lab.")
(license license:agpl3+)))
+
+(define-public cityhash
+ (let ((commit "8af9b8c")
+ (revision "1"))
+ (package
+ (name "cityhash")
+ (version (string-append "1.1." revision "." commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/cityhash.git")
+ (commit commit)))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0n6skf5dv8yfl1ckax8dqhvsbslkwc9158zf2ims0xqdvzsahbi6"))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/google/cityhash")
+ (synopsis "C++ hash functions for strings")
+ (description
+ "CityHash provides hash functions for strings. The functions mix the
+input bits thoroughly but are not suitable for cryptography.")
+ (license license:expat))))