aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-04 22:35:15 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-09 22:57:45 +0100
commit688fe86587083c37d5e63ec9ac7c7d11fe689ace (patch)
tree599bdfac67bfbe66cf12903fa856cadd92028ee6 /gnu/packages/textutils.scm
parent7939e70a3256e40366e0226c9b75e6c5b7768925 (diff)
downloadguix-688fe86587083c37d5e63ec9ac7c7d11fe689ace.tar
guix-688fe86587083c37d5e63ec9ac7c7d11fe689ace.tar.gz
gnu: Add enca.
* gnu/packages/textutils.scm (enca): New variable.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 17e665a216..deefc42ac9 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -58,3 +58,23 @@ any pair. When exact transliteration are not possible, it gets rid of
offending characters or falls back on approximations. The recode program is a
handy front-end to the library.")
(license license:gpl2+)))
+
+(define-public enca
+ (package
+ (name "enca")
+ (version "1.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/nijel/enca/archive/" version ".tar.gz"))
+ (sha256
+ (base32 "1xik00x0yvhswsw2isnclabhv536xk1s42cf5z54gfbpbhc7ni8l"))))
+ (build-system gnu-build-system)
+ (inputs `(("recode" ,recode)))
+ (home-page "https://github.com/nijel/enca")
+ (synopsis "Text encoding detection tool")
+ (description "Enca (Extremely Naive Charset Analyser) consists of libenca,
+an encoding detection library, and enca, a command line frontend, integrating
+libenca and several charset conversion libraries and tools.")
+ (license license:gpl2)))