aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2016-05-07 12:16:39 -0500
committerAlex Kost <alezost@gmail.com>2016-05-16 18:01:18 +0300
commitf17a54475656f16867767ecfd512552e5f547cf1 (patch)
tree3d49007e81fc3d02b8dd1c03022636bf23809b4c /gnu/packages/textutils.scm
parent80ed14d38f098f25f87efb01288cd6df8b307b7b (diff)
downloadguix-f17a54475656f16867767ecfd512552e5f547cf1.tar
guix-f17a54475656f16867767ecfd512552e5f547cf1.tar.gz
gnu: Add utfcpp.
* gnu/packages/textutils.scm (utfcpp): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm44
1 files changed, 43 insertions, 1 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index f6735a43e0..080c95ba1c 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015, 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
+;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,8 +28,10 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages autotools)
- #:use-module (gnu packages python))
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages zip))
(define-public recode
(package
@@ -328,3 +331,42 @@ name comes from: \"The antidote against people who send Microsoft Word files
to everybody, because they believe that everybody runs Windows and therefore
runs Word\".")
(license license:gpl2+)))
+
+(define-public utfcpp
+ (package
+ (name "utfcpp")
+ (version "2.3.4")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "mirror://sourceforge/project/utfcpp/utf8cpp_2x/Release%20"
+ version "/utf8_v"
+ (string-map (lambda (x) (if (eq? x #\.) #\_ x)) version)
+ ".zip"))
+ (file-name (string-append name "-" version ".zip"))
+ (sha256
+ (base32
+ "1vqhs0aipcvvdrwcs7h3jsryg6mgbmc4s34n5cm6d36q4nxwwwrk"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((source (assoc-ref %build-inputs "source"))
+ (out (assoc-ref %outputs "out"))
+ (unzip (string-append (assoc-ref %build-inputs "unzip")
+ "/bin/unzip")))
+ (mkdir-p out)
+ (with-directory-excursion out
+ (system* unzip source)
+ (mkdir-p "share/doc")
+ (rename-file "doc" "share/doc/utfcpp")
+ (rename-file "source" "include"))))))
+ (native-inputs `(("unzip" ,unzip)))
+ (home-page "https://github.com/nemtrif/utfcpp")
+ (synopsis "Portable C++ library for handling UTF-8")
+ (description "UTF8-CPP is a C++ library for handling UTF-8 encoded text
+in a portable way.")
+ (license license:boost1.0)))