aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-19 08:34:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-12-19 13:16:36 +0100
commitb28e05d45e9d9485113ad1535b5572f4eab77da5 (patch)
tree6bf0a0917d42daacd7881bd8db8f65412c61aa43 /gnu/packages/textutils.scm
parentfb6ca493f1416761129a139b36d40c2153dd4af2 (diff)
downloadguix-b28e05d45e9d9485113ad1535b5572f4eab77da5.tar
guix-b28e05d45e9d9485113ad1535b5572f4eab77da5.tar.gz
gnu: antiword: Fix broken embedded directory name.
* gnu/packages/textutils.scm (antiword)[arguments]: Replace "configure" phase to substitute reference to "/usr/share/antiword" with the actual directory in the store.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 674a3507d0..2fb1d1495e 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -388,7 +388,14 @@ regular expression object can be specified.")
(assoc-ref %outputs "out") "/share/antiword"))
#:phases
(modify-phases %standard-phases
- (delete 'configure)
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Ensure that mapping files can be found in the actual package
+ ;; data directory.
+ (substitute* "antiword.h"
+ (("/usr/share/antiword")
+ (string-append (assoc-ref outputs "out") "/share/antiword")))
+ #t))
(replace 'install
(lambda* (#:key make-flags #:allow-other-keys)
(zero? (apply system* "make" `("global_install" ,@make-flags))))))))