aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-04-28 08:11:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-05-01 18:15:59 +0200
commit1b90e57eb75e760bd83acb39a0f8085d22d3813d (patch)
tree0becdcde702335fbfdd3f0a12a4692052572a93f /gnu/packages/textutils.scm
parenta66a60f251e38424078f2881522d0956e2f3643a (diff)
downloadguix-1b90e57eb75e760bd83acb39a0f8085d22d3813d.tar
guix-1b90e57eb75e760bd83acb39a0f8085d22d3813d.tar.gz
gnu: Add antiword.
* gnu/packages/textutils.scm (antiword): New variable.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 71cf25b224..f6735a43e0 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -292,3 +292,39 @@ as existing hashing techniques, with provably negligible risk of collisions.")
characteristic of this library is that different character encoding for every
regular expression object can be specified.")
(license license:bsd-2)))
+
+(define-public antiword
+ (package
+ (name "antiword")
+ (version "0.37")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.winfield.demon.nl/linux"
+ "/antiword-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1b7mi1l20jhj09kyh0bq14qzz8vdhhyf35gzwsq43mn6rc7h0b4f"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests
+ #:make-flags
+ (list "-f" "Makefile.Linux"
+ (string-append "GLOBAL_INSTALL_DIR="
+ (assoc-ref %outputs "out") "/bin")
+ (string-append "GLOBAL_RESOURCES_DIR="
+ (assoc-ref %outputs "out") "/share/antiword"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (zero? (apply system* "make" `("global_install" ,@make-flags))))))))
+ (home-page "http://www.winfield.demon.nl/")
+ (synopsis "Microsoft Word document reader")
+ (description "Antiword is an application for displaying Microsoft Word
+documents. It can also convert the document to PostScript or XML. Only
+documents made by MS Word version 2 and version 6 or later are supported. The
+name comes from: \"The antidote against people who send Microsoft Word files
+to everybody, because they believe that everybody runs Windows and therefore
+runs Word\".")
+ (license license:gpl2+)))