aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-11 11:37:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-11 11:37:01 +0100
commit08bc7f26653a407ccd7f07c07a81a538e9f44313 (patch)
treed6a20f8e956e8328ad9ece341f0a5b016c87dde0 /gnu/packages/textutils.scm
parent7a52d0e075baebe2c04331b82d5974f2db9bf9f0 (diff)
downloadguix-08bc7f26653a407ccd7f07c07a81a538e9f44313.tar
guix-08bc7f26653a407ccd7f07c07a81a538e9f44313.tar.gz
gnu: dotconf: Fetch sources from git.
* gnu/packages/textutils.scm (dotconf)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index c814e988b1..e9a4ab3d68 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -568,14 +568,14 @@ categories.")
(name "dotconf")
(version "1.3")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/williamh/dotconf/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/williamh/dotconf.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0lsnh0yaw44psmx59hq94cj1932gscp5h8d3cnh05l0svr0cy7kz"))))
+ "1sc95hw5k2xagpafny0v35filmcn05k1ds5ghkldfpf6xw4hakp7"))))
(build-system gnu-build-system)
(arguments `(#:tests? #f)) ; FIXME maketest.sh does not work.
(native-inputs