aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-29 14:23:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-29 14:23:56 +0200
commitc7f7a5bac27d6525c4f407aa31b5e9fcc0ab07d6 (patch)
treeb4cabfccdaaea662b426a5774cd1c87ef01c437e /gnu/packages/text-editors.scm
parent04952bd7321c2607e51af2d11c1248d9462343ff (diff)
downloadguix-c7f7a5bac27d6525c4f407aa31b5e9fcc0ab07d6.tar
guix-c7f7a5bac27d6525c4f407aa31b5e9fcc0ab07d6.tar.gz
gnu: kakoune: Fix build after Boost ABI change.
Also remove now-obsolete snippet and inputs. * gnu/packages/text-editors.scm (kakoune)[source]: Remove gzip substitution. [arguments]: Drop CPPFLAGS from #:make-flags. [native-inputs]: Remove GCC-5. [inputs]: Remove gcc:lib.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm21
1 files changed, 4 insertions, 17 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index a093baa3bd..f860b0e8a8 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -99,21 +99,10 @@ based command language.")
(commit commit)))
(sha256
(base32
- "19qs99l8r9p1vi5pxxx9an22fvi7xx40qw3jh2cnh2mbacawvdyb"))
- (modules '((guix build utils)))
- (snippet
- ;; Kakoune uses 'gzip' to compress its manpages. Make sure
- ;; timestamps are not preserved for reproducibility.
- '(begin
- (substitute* "src/Makefile"
- (("gzip -f") "gzip -f --no-name"))
- #t))))
+ "19qs99l8r9p1vi5pxxx9an22fvi7xx40qw3jh2cnh2mbacawvdyb"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- ;; Boost is compiled with the older ABI, so we can't use
- ;; the new ABI if we want to link againt it.
- "CPPFLAGS=-D_GLIBCXX_USE_CXX11_ABI=0")
+ `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -136,11 +125,9 @@ based command language.")
;; Out git downloader doesn't give us write permissions, but
;; without them the tests fail.
(zero? (system* "chmod" "-R" "u+w" "../test")))))))
- (native-inputs `(("gcc" ,gcc-5)
- ("asciidoc" ,asciidoc)
+ (native-inputs `(("asciidoc" ,asciidoc)
("ruby" ,ruby)))
- (inputs `(("gcc:lib" ,gcc-5 "lib")
- ("ncurses" ,ncurses)
+ (inputs `(("ncurses" ,ncurses)
("boost" ,boost)))
(synopsis "Vim-inspired code editor")
(description