aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMatthieu Lemerre <racin@free.fr>2023-04-18 14:28:36 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:23 -0400
commit79d5721a038b59b5d0c4e5e2f391d87888898eae (patch)
tree51ecb6b7dff49190cab13e9c9e4b6dd3ee102940 /gnu/packages/tex.scm
parent919a08b3d5ac32036334766697ee322ca7b3c67f (diff)
downloadguix-79d5721a038b59b5d0c4e5e2f391d87888898eae.tar
guix-79d5721a038b59b5d0c4e5e2f391d87888898eae.tar.gz
gnu: Add texlive-totpages.
* gnu/packages/tex.scm (texlive-totpages): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1d98662777..4e4a7b4aef 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13381,6 +13381,48 @@ changed, the recorded value will usually be the maximum value.")
(define-deprecated-package texlive-latex-totcount texlive-totcount)
+(define-public texlive-totpages
+ (let ((template (simple-texlive-package
+ "texlive-totpages"
+ (list "doc/latex/totpages/"
+ "source/latex/totpages/"
+ "tex/latex/totpages/")
+ (base32
+ "1mmya2fqdskyavw3hvdiygfyp9cll7bl4lpi7pl2jf9s7ds49j5a"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t) "latex/totpages")
+ ((#:tex-format _ #t) "latex")
+ ((#:build-targets _ '()) '(list "totpages.ins"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/totpages/")))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (native-inputs
+ (list (texlive-updmap.cfg)))
+ (propagated-inputs
+ (list texlive-everyshi texlive-latex-graphics))
+ (home-page "https://ctan.org/pkg/totpages")
+ (synopsis "Count pages in a document, and report last page number")
+ (description
+ "The package counts the actual pages in the document (as opposed to
+reporting the number of the last page, as does @code{lastpage}). The counter
+itself may be shipped out to the DVI file.")
+ (license license:lppl))))
+
(define-public texlive-xetex
(package
(inherit (simple-texlive-package