aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 00:21:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:40:02 +0200
commitda9085549c9042aab1b97c371d425a02a2bbe9df (patch)
tree9bdec565d1a50b4fccf8c578282713b8511945e3 /gnu/packages/tex.scm
parent56629705d1d94c0313f21e734dce3240acbf8942 (diff)
downloadguix-da9085549c9042aab1b97c371d425a02a2bbe9df.tar
guix-da9085549c9042aab1b97c371d425a02a2bbe9df.tar.gz
gnu: Add texlive-mex.
* gnu/packages/tex.scm (texlive-mex): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9a815d027e..4a9a1de009 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6404,6 +6404,38 @@ ranging from very simple (lines and circles) to rather intricate (uncommon
geometric transformations, fractals, bitmap, etc).")
(license license:gpl1+)))
+(define-public texlive-mex
+ (package
+ (name "texlive-mex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/mex/base/" "source/mex/base/"
+ "tex/mex/base/" "tex/mex/config/")
+ (base32
+ "0kc766cvvbcqrj60ncz4a105nrn454y5c2330y7s7jzh45dx8qsi")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:create-formats #~(list "mex" "pdfmex" "utf8mex")))
+ (propagated-inputs
+ (list texlive-enctex
+ texlive-hyphen-complete
+ texlive-knuth-lib
+ texlive-pdftex
+ texlive-pl
+ texlive-plain
+ texlive-tex
+ texlive-tex-ini-files
+ texlive-utf8mex))
+ (home-page "https://ctan.org/pkg/mex")
+ (synopsis "Polish formats for TeX")
+ (description
+ "MeX is an adaptation of Plain TeX (MeX) and LaTeX209 (LaMeX) formats to
+the Polish language and to Polish printing customs. It contains a complete
+set of Metafont sources of Polish fonts, hyphenation rules for the Polish
+language and sources of formats.")
+ (license license:knuth)))
+
(define-public texlive-mgltex
(package
(name "texlive-mgltex")