aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-03-14 20:25:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-03-14 21:16:46 +0200
commitf73020735cc9e7d02d1f77eeb3af1d2fae090b56 (patch)
tree90bd6a50af5a96db94ebfb088f53311f2ee2760f /gnu/packages/tex.scm
parent88e11022db4af72a0b33a0af7c71230234ce5e17 (diff)
downloadguix-f73020735cc9e7d02d1f77eeb3af1d2fae090b56.tar
guix-f73020735cc9e7d02d1f77eeb3af1d2fae090b56.tar.gz
gnu: texlive-latex-graphics: Declare a source file-name.
* gnu/packages/tex.scm (texlive-latex-graphics)[source]: Declare a source file-name. [native-inputs]: Declare a source file-name for downloaded native-inputs.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f0f0955949..ae3c7b3abd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1152,6 +1152,7 @@ verbatim source).")
(source (origin
(method svn-fetch)
(uri (texlive-ref "latex" "graphics"))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
"07azyn0b1s49vbdlr6dmygrminxp72ndl24j1091hiiccvrjq3xc"))))
@@ -1184,6 +1185,9 @@ verbatim source).")
(uri (git-reference
(url "https://github.com/latex3/graphics-cfg.git")
(commit "19d1238af17df376cd46333b229579b0f7f3a41f")))
+ (file-name (string-append "graphics-cfg-"
+ (number->string %texlive-revision)
+ "-checkout"))
(sha256
(base32
"12kbgbm52gmmgn8zajb74s8n5rvnxcfdvs3iyj8vcw5vrsw5i6mh"))))
@@ -1195,6 +1199,9 @@ verbatim source).")
%texlive-tag "/Master/texmf-dist/"
"/tex/latex/graphics-def"))
(revision %texlive-revision)))
+ (file-name (string-append "graphics-def-"
+ (number->string %texlive-revision)
+ "-checkout"))
(sha256
(base32
"0gi4qv6378nl84s8n1yx3hjqvv7r4lza7hpbymbl5rzwgw8qrnyb"))))))