aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-04-10 12:54:09 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-04-21 00:19:15 +0530
commita9fda571c3e702ccd6b40f7ee320e55fd2e83d19 (patch)
treedb67f856c59831d7f2f2b7d3f643a01640c28e62 /gnu/packages/tex.scm
parent5d904d63f4d43e3f0e4be38c5f5404e029c00a22 (diff)
downloadguix-a9fda571c3e702ccd6b40f7ee320e55fd2e83d19.tar
guix-a9fda571c3e702ccd6b40f7ee320e55fd2e83d19.tar.gz
gnu: texlive-bin: Use ghostscript executable "gs" in ps2eps.
* gnu/packages/tex.scm (texlive-bin)[arguments]: Add fix-unix-detection phase. Replace system* with invoke in postint phase.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index db1f120ce6..2b35250dd0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Danny Milosavljevic <dannym+a@scratchpost.org>
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -175,6 +176,15 @@
(string-prefix? "mips64" s))))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-unix-detection
+ ;; ps2eps.pl uses the "gswin32c" ghostscript executable on Windows,
+ ;; and the "gs" ghostscript executable on Unix. It detects Unix by
+ ;; checking for the existence of the /usr/bin directory. Since
+ ;; GuixSD does not have /usr/bin, it is also detected as Windows.
+ (lambda _
+ (substitute* "utils/ps2eps/ps2eps-src/bin/ps2eps.pl"
+ (("gswin32c") "gs"))
+ #t))
(add-after 'install 'postint
(lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
(let* ((out (assoc-ref outputs "out"))
@@ -196,7 +206,7 @@
(with-directory-excursion "texlive-extra"
(apply unpack (list #:source texlive-extra))
(apply patch-source-shebangs (list #:source texlive-extra))
- (system* "mv" "tlpkg" share))))))))
+ (invoke "mv" "tlpkg" share))))))))
(synopsis "TeX Live, a package of the TeX typesetting system")
(description
"TeX Live provides a comprehensive TeX document production system.