aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-12-31 15:00:35 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2018-02-15 21:44:06 +0100
commite79a8424ca0815d536913a39d91b45dd690062d0 (patch)
tree9977f0ba6118c61037d621aa9e058af054811730 /gnu/packages/terminals.scm
parent573450e60cc7c8f5475c2c1432c0a0ee11737ebc (diff)
downloadguix-e79a8424ca0815d536913a39d91b45dd690062d0.tar
guix-e79a8424ca0815d536913a39d91b45dd690062d0.tar.gz
gnu: Add python-curtsies.
* gnu/packages/terminals.scm (python-curtsies, python2-curtsies): New variables.
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 3c74f9807d..eeae8bea41 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -741,3 +741,39 @@ than a terminal.")
(define-public python2-blessings
(package-with-python2 python-blessings))
+
+(define-public python-curtsies
+ (package
+ (name "python-curtsies")
+ (version "0.2.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "curtsies" version))
+ (sha256
+ (base32
+ "1vljmw3sy6lrqahhpyg4gk13mzcx3mwhvg8s41698ms3cpgkjipc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "nosetests" "-v"))))))
+ (propagated-inputs
+ `(("python-blessings" ,python-blessings)
+ ("python-wcwidth", python-wcwidth)))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pyte" ,python-pyte)
+ ("python-nose" ,python-nose)))
+ (home-page "https://github.com/thomasballinger/curtsies")
+ (synopsis "Library for curses-like terminal interaction with colored
+strings")
+ (description "Curtsies is a Python library for interacting with the
+terminal. It features string-like objects which carry formatting information,
+per-line fullscreen terminal rendering, and keyboard input event reporting.")
+ (license license:expat)))
+
+(define-public python2-curtsies
+ (package-with-python2 python-curtsies))