aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorJosé Miguel Sánchez García <jmi2k@openmailbox.org>2016-12-07 18:03:09 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-07 23:09:49 +0100
commitdb913ac431fbffb54465f51cb499e886b21c34fd (patch)
tree06dbd57d629325c398d2b77b59236bb77aed2ae9 /gnu/packages/terminals.scm
parent3593e5d5c50b08cf69739aac98cd7c89247fa6da (diff)
downloadguix-db913ac431fbffb54465f51cb499e886b21c34fd.tar
guix-db913ac431fbffb54465f51cb499e886b21c34fd.tar.gz
gnu: Add libtermkey.
* gnu/packages/terminals.scm (libtermkey): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index e1076c7c60..efedba480f 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 José Miguel Sánchez García <jmi2k@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +37,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages wm)
@@ -261,6 +263,35 @@ multi-seat support, a replacement for @command{mingetty}, and more.")
(supported-systems (filter (cut string-suffix? "-linux" <>)
%supported-systems))))
+(define-public libtermkey
+ (package
+ (name "libtermkey")
+ (version "0.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.leonerd.org.uk/code/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32 "09ir16kaarv55mnc4jn2sqnjjhzpb1aha51wpd9ayif887g4d5r3"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list
+ "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))
+ #:test-target "test"))
+ (inputs `(("ncurses", ncurses)))
+ (native-inputs `(("libtool", libtool)
+ ("perl-test-harness" ,perl-test-harness)
+ ("pkg-config", pkg-config)))
+ (synopsis "Keyboard entry processing library for terminal-based programs")
+ (description
+ "Libtermkey handles all the necessary logic to recognise special keys, UTF-8
+combining, and so on, with a simple interface.")
+ (home-page "http://www.leonerd.org.uk/code/libtermkey")
+ (license license:expat)))
+
(define-public picocom
(package
(name "picocom")