aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-13 10:21:17 -0500
committerLeo Famulari <leo@famulari.name>2017-01-13 10:21:17 -0500
commitcc0725914e74c4c4dec369f3e7cdb6f201b3fecd (patch)
treee68b452ed625a2db8ed10914fb0968fdc36c655d /gnu/packages/terminals.scm
parenta25b6880f1398ad36aea1d0e4e4105936a8b7e70 (diff)
parentce195ba12277ec4286ad0d8ddf7294655987ea9d (diff)
downloadguix-cc0725914e74c4c4dec369f3e7cdb6f201b3fecd.tar
guix-cc0725914e74c4c4dec369f3e7cdb6f201b3fecd.tar.gz
Merge branch 'master' into python-tests
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm42
1 files changed, 39 insertions, 3 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 79da6c7127..8e648c4031 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -4,7 +4,8 @@
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 José Miguel Sánchez García <jmi2k@openmailbox.org>
+;;; Copyright © 2016, 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -269,13 +270,13 @@ multi-seat support, a replacement for @command{mingetty}, and more.")
(define-public libtermkey
(package
(name "libtermkey")
- (version "0.18")
+ (version "0.19")
(source (origin
(method url-fetch)
(uri (string-append "http://www.leonerd.org.uk/code/"
name "/" name "-" version ".tar.gz"))
(sha256
- (base32 "09ir16kaarv55mnc4jn2sqnjjhzpb1aha51wpd9ayif887g4d5r3"))))
+ (base32 "1ds8gdr8p2dfr970z8kxgfz6x7m1jxmmfrb2aafab3wcni6al1f5"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list
@@ -329,3 +330,38 @@ configuration, testing, and debugging tool. It has also serves well
as a low-tech serial communications program to allow access to all
types of devices that provide serial consoles.")
(license license:gpl2+)))
+
+(define-public beep
+ (package
+ (name "beep")
+ (version "1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.johnath.com/" name "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0bgch6jq5cahakk3kbr9549iysf2dik09afixxy5brbxk1xfzb2r"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'patch-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile" (("/usr") (assoc-ref outputs "out")))
+ #t))
+ (add-before 'install 'create-output-directories
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref %outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ (mkdir-p (string-append out "/man/man1"))))))))
+ (synopsis "Linux command-line utility to control the PC speaker")
+ (description "beep allows the user to control the PC speaker with precision,
+allowing different sounds to indicate different events. While it can be run
+quite happily on the command line, its intended place of residence is within
+scripts, notifying the user when something interesting occurs. Of course, it
+has no notion of what's interesing, but it's very good at that notifying part.")
+ (home-page "http://www.johnath.com/beep")
+ (license license:gpl2+)))