aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2016-07-27 16:22:32 -0500
committerLudovic Courtès <ludo@gnu.org>2016-07-28 15:43:40 +0200
commitcb55f9c652105d9ed4fc46cb902f0935fe7e35f8 (patch)
treeaa4433ba5b1c2be9db3b8ed067c45cc4c38366a8 /gnu/packages/terminals.scm
parent71d9b98078e8c785ad57cf3ae2e70939e815a82f (diff)
downloadguix-cb55f9c652105d9ed4fc46cb902f0935fe7e35f8.tar
guix-cb55f9c652105d9ed4fc46cb902f0935fe7e35f8.tar.gz
gnu: Add asciinema.
* gnu/packages/terminals.scm (asciinema): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index ee36f64354..98f0060c0d 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Mckinley Olsen <mck.olsen@gmail.com>
+;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
@@ -30,6 +32,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
#:use-module (gnu packages wm)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages gtk)
@@ -121,3 +124,38 @@ insert mode and command mode where keybindings have different functions.")
;; Files under util/ are under the Expat license; the rest is LGPLv2+.
(license license:lgpl2.0+)))
+
+(define-public asciinema
+ (package
+ (name "asciinema")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/06/96/93947d9be78aebb7985014fdf"
+ "4d84896dd0f62514d922ee03f5bb55a21fb/asciinema-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1crdm9zfdbjflvz1gsqvy5zsbgwdfkj34z69kg6h5by70rrs1hdc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((ncurses (assoc-ref inputs "ncurses")))
+ (substitute* "asciinema/recorder.py"
+ (("'tput'")
+ (string-append "'" ncurses "/bin/tput'"))))
+ #t)))))
+ (inputs `(("ncurses" ,ncurses)
+ ("python-setuptools" ,python-setuptools)))
+ (home-page "https://asciinema.org")
+ (synopsis "Terminal session recorder")
+ (description
+ "Use asciinema to record and share your terminal sessions, the right way.
+Forget screen recording apps and blurry video. Enjoy a lightweight, purely
+text-based approach to terminal recording.")
+ (license license:gpl3)))