aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-28 19:33:40 -0500
committerLeo Famulari <leo@famulari.name>2018-02-08 15:18:20 -0500
commit4b6b1a385694cdfcc1bee87feff7be53aa3d9bc3 (patch)
tree05b2ea80892811408b62bf4eef329724fbb2419e /gnu/packages/syncthing.scm
parent339e44dac20ee24a706878093a5756f0eec4c95f (diff)
downloadguix-4b6b1a385694cdfcc1bee87feff7be53aa3d9bc3.tar
guix-4b6b1a385694cdfcc1bee87feff7be53aa3d9bc3.tar.gz
gnu: Add go-github-com-prometheus-client-model-go.
* gnu/packages/syncthing.scm (go-github-com-prometheus-client-model-go): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 904f32fc52..075836791f 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1980,3 +1980,30 @@ bounds.")
data serialization format.")
(home-page "https://github.com/golang/protobuf")
(license bsd-3))))
+
+(define-public go-github-com-prometheus-client-model-go
+ (let ((commit "99fa1f4be8e564e8a6b613da7fa6f46c9edafc6c")
+ (revision "0"))
+ (package
+ (name "go-github-com-prometheus-client-model-go")
+ (version (git-version "0.0.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prometheus/client_model.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19y4ywsivhpxj7ikf2j0gm9k3cmyw37qcbfi78n526jxcc7kw998"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/prometheus/client_model/go"
+ #:unpack-path "github.com/prometheus/client_model"))
+ (propagated-inputs
+ `(("go-github-com-golang-protobuf-proto"
+ ,go-github-com-golang-protobuf-proto)))
+ (synopsis "Data model artifacts for Prometheus")
+ (description "This package provides data model artifacts for Prometheus.")
+ (home-page "https://github.com/prometheus/client_model")
+ (license asl2.0))))