aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-28 19:39:06 -0500
committerLeo Famulari <leo@famulari.name>2018-02-08 15:18:20 -0500
commit270590bd69849c6a85e94d9dfb96657c1aa222c2 (patch)
treec873acd088b43f46fb1bfcca10df204d90dc1a3c /gnu/packages/syncthing.scm
parent1da227b0d88c2fabda3a2e6a44b6ec28e48f3aa4 (diff)
downloadguix-270590bd69849c6a85e94d9dfb96657c1aa222c2.tar
guix-270590bd69849c6a85e94d9dfb96657c1aa222c2.tar.gz
gnu: Add go-github-com-prometheus-common-expfmt.
* gnu/packages/syncthing.scm (go-github-com-prometheus-common-expfmt): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index b1bca8e9a3..e7c6477313 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -2038,3 +2038,46 @@ extensions for the Go language, namely support for record length-delimited
message streaming.")
(home-page "https://github.com/matttproud/golang_protobuf_extensions")
(license asl2.0))))
+
+(define-public go-github-com-prometheus-common-expfmt
+ (let ((commit "2e54d0b93cba2fd133edc32211dcc32c06ef72ca")
+ (revision "0"))
+ (package
+ (name "go-github-com-prometheus-common-expfmt")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prometheus/common.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14kn5w7imcxxlfdqxl21fsnlf1ms7200g3ldy29hwamldv8qlm7j"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/prometheus/common/expfmt"
+ #:unpack-path "github.com/prometheus/common"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (map (lambda (file)
+ (make-file-writable file))
+ (find-files
+ (string-append (assoc-ref outputs "out")
+ "/src/github.com/prometheus/common/expfmt/testdata/")
+ ".*\\.gz$"))
+ #t)))))
+ (propagated-inputs
+ `(("go-github-com-golang-protobuf-proto"
+ ,go-github-com-golang-protobuf-proto)
+ ("go-github-com-matttproud-golang-protobuf-extensions-pbutil"
+ ,go-github-com-matttproud-golang-protobuf-extensions-pbutil)
+ ("go-github-com-prometheus-client-model-go"
+ ,go-github-com-prometheus-client-model-go)))
+ (synopsis "Prometheus metrics")
+ (description "This package provides tools for reading and writing
+Prometheus metrics.")
+ (home-page "https://github.com/prometheus/common")
+ (license asl2.0))))