aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/swig.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-07-18 10:06:13 +0200
committerJohn Darrington <jmd@gnu.org>2014-07-20 10:12:16 +0200
commit0a643dc6f417a951f3d0b09ffdf7d1df423c84f8 (patch)
treec68d329593fe7578d659c10791777cede957b54b /gnu/packages/swig.scm
parent428a62f2570b1b4ea2e7d9029f8e096eb4f6451c (diff)
downloadguix-0a643dc6f417a951f3d0b09ffdf7d1df423c84f8.tar
guix-0a643dc6f417a951f3d0b09ffdf7d1df423c84f8.tar.gz
gnu: Enable swig tests.
* gnu/packages/swig.scm (swig): Add boost as input and enable tests.
Diffstat (limited to 'gnu/packages/swig.scm')
-rw-r--r--gnu/packages/swig.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index 355480341f..7f7d319fab 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -23,6 +23,7 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages pcre)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages python)
#:use-module (gnu packages perl)
#:export (swig))
@@ -39,11 +40,7 @@
(base32
"0kj21b6syp62vx68r1j6azv9033kng68pxm1k79pm4skkzr0ny33"))))
(build-system gnu-build-system)
- (arguments '(#:configure-flags '("--without-boost")
-
- ;; FIXME: Some tests require Boost anyway. Turn them on when
- ;; we have Boost.
- #:tests? #f))
+ (native-inputs `(("boost" ,boost)))
(inputs `(("pcre" ,pcre)
;; Provide these to run the corresponding tests.