aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-09 17:02:08 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-09 17:02:08 +0100
commit64461ba20a07a0cf3197de3e97cb44e0f66cebdc (patch)
treef48fd8e66879da30d5e2d89b16de6294ecd1192d /gnu/packages/statistics.scm
parent55174e668f2985d1c4efda4fbf58f4061dde0db2 (diff)
parentcee9ab244f9ba9f3156b6aa50927418bae951096 (diff)
downloadguix-64461ba20a07a0cf3197de3e97cb44e0f66cebdc.tar
guix-64461ba20a07a0cf3197de3e97cb44e0f66cebdc.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index bb942b4fea..9bfa4c5683 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -39,6 +39,7 @@
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -75,7 +76,7 @@
(define-public pspp
(package
(name "pspp")
- (version "1.0.1")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
@@ -83,7 +84,7 @@
version ".tar.gz"))
(sha256
(base32
- "1r8smr5057993h90nx0mdnff8nxw9x546zzh6qpy4h3xblp1la5s"))))
+ "07pp27zycrb5x927jwaj9r3q7hy915jh51xs85zxby6gfiwl63m5"))))
(build-system gnu-build-system)
(inputs
`(("cairo" ,cairo)
@@ -94,11 +95,15 @@
("readline" ,readline)
("gtk" ,gtk+)
("gtksourceview" ,gtksourceview)
+ ("spread-sheet-widget" ,spread-sheet-widget)
("zlib" ,zlib)))
(native-inputs
- `(("glib" ,glib "bin") ;for glib-genmarshal
+ `(("autoconf" ,autoconf) ;for tests
+ ("glib" ,glib "bin") ;for glib-genmarshal
("perl" ,perl)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-2) ;for tests
+ ("texinfo" ,texinfo)))
(home-page "https://www.gnu.org/software/pspp/")
(synopsis "Statistical analysis")
(description
@@ -116,7 +121,7 @@ be output in text, PostScript, PDF or HTML.")
(define r-with-tests
(package
(name "r-with-tests")
- (version "3.5.0")
+ (version "3.5.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cran/src/base/R-"
@@ -124,7 +129,7 @@ be output in text, PostScript, PDF or HTML.")
version ".tar.gz"))
(sha256
(base32
- "0w38865laqg28cdhikxdxhx4rfp0kgcn72gakwypsy91br9ja5zx"))))
+ "1vap2k8kj5icy9naw61f9zyphf4rs0c9rxvil0zxkwx0xvsvyqq4"))))
(build-system gnu-build-system)
(arguments
`(#:disallowed-references (,tzdata-for-tests)