aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-05-18 21:47:35 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-05-19 22:13:43 +1000
commit0947698c42fb10b8802679cbc58f9a42a2d91043 (patch)
treef0c7dbfd263bee6d562e787e90889d658b71731a /gnu/packages/statistics.scm
parent44c5f0258d3c91694e6c24dcc6701eb2949fd5d8 (diff)
downloadguix-0947698c42fb10b8802679cbc58f9a42a2d91043.tar
guix-0947698c42fb10b8802679cbc58f9a42a2d91043.tar.gz
gnu: Add r-biased-urn.
* gnu/packages/statistics.scm (r-biased-urn): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 7b3483206f..58f5c9d644 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2593,6 +2594,28 @@ directly from R. Once uploaded to a plotly account, plotly graphs (and the
data behind them) can be viewed and modified in a web browser.")
(license license:x11)))
+(define-public r-biased-urn
+ (package
+ (name "r-biased-urn")
+ (version "1.07")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "BiasedUrn" version))
+ (sha256
+ (base32
+ "13i2lgfnjhlbbm2yxfc2l5hswqw6x03pwba5csjmirv8kpjw4xr3"))))
+ (properties `((upstream-name . "BiasedUrn")))
+ (build-system r-build-system)
+ (home-page "http://www.agner.org/random/")
+ (synopsis "Biased urn model distributions")
+ (description
+ "This package provides statistical models of biased sampling in the form
+of univariate and multivariate noncentral hypergeometric distributions,
+including Wallenius' noncentral hypergeometric distribution and Fisher's
+noncentral hypergeometric distribution (also called extended hypergeometric
+distribution).")
+ (license license:gpl3+)))
(define-public r-ztable
(package