aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sourcehut.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2024-02-22 20:47:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:25 +0000
commit6d97c15911a51d29f91e3656f9c4ab38e08d7f21 (patch)
treea42bcc8f38f2532ca0218d92323c993729912961 /gnu/packages/sourcehut.scm
parent1ef178c644178304b24bd29c7563ab0529c15f8f (diff)
downloadguix-6d97c15911a51d29f91e3656f9c4ab38e08d7f21.tar
guix-6d97c15911a51d29f91e3656f9c4ab38e08d7f21.tar.gz
gnu: Add python-setuptools/python-wheel where necessary.
Changes to pyproject-build-system require explicit dependency on setuptools/wheel. Change-Id: Icd7699fc1dc56e974ae7568f2ae916dbf876bea5
Diffstat (limited to 'gnu/packages/sourcehut.scm')
-rw-r--r--gnu/packages/sourcehut.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/sourcehut.scm b/gnu/packages/sourcehut.scm
index 9222101b84..00557e5b2e 100644
--- a/gnu/packages/sourcehut.scm
+++ b/gnu/packages/sourcehut.scm
@@ -74,6 +74,7 @@
python-requests
python-sqlalchemy
python-sqlalchemy-utils))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://git.sr.ht/~sircmpwn/core.sr.ht")
(synopsis "Shared code for all sourcehut projects")
(description
@@ -104,6 +105,7 @@
(lambda _ (setenv "PKGVER" #$version))))))
(propagated-inputs
(list python-core-sr-ht))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://git.sr.ht/~sircmpwn/scm.sr.ht")
(synopsis "Shared support code for sr.ht source control services")
(description