aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/socat.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-29 16:26:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-05-03 21:48:02 +0200
commit8a413bcaf5dd845c6c5146a4f05e08529ab3e34f (patch)
tree51b31f2343a397299ec00cfa9898884151ab5b26 /gnu/packages/socat.scm
parentd5e9f3809dc7d521874cfad0a242ab664f6c19bc (diff)
downloadguix-8a413bcaf5dd845c6c5146a4f05e08529ab3e34f.tar
guix-8a413bcaf5dd845c6c5146a4f05e08529ab3e34f.tar.gz
gnu: rename (gnu packages socat) to (gnu packages networking).
* gnu/packages/socat.scm: Rename this ... * gnu/packages/networking.scm: ... to this. * gnu-system.am (GNU_SYSTEM_MODULES): Change socat.scm to networking.scm.
Diffstat (limited to 'gnu/packages/socat.scm')
-rw-r--r--gnu/packages/socat.scm55
1 files changed, 0 insertions, 55 deletions
diff --git a/gnu/packages/socat.scm b/gnu/packages/socat.scm
deleted file mode 100644
index 7c0bc3d964..0000000000
--- a/gnu/packages/socat.scm
+++ /dev/null
@@ -1,55 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages socat)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages openssl))
-
-;; XXX: Group with other networking tools like tcpdump in a module?
-(define-public socat
- (package
- (name "socat")
- (version "1.7.2.4")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://www.dest-unreach.org/socat/download/socat-"
- version ".tar.bz2"))
- (sha256
- (base32
- "028yjka2zr6j1i8pmfmvzqki8ajczdl1hnry1x31xbbg3j83jxsb"))))
- (build-system gnu-build-system)
- (arguments '(#:tests? #f)) ;no 'check' phase
- (inputs `(("openssl" ,openssl)))
- (home-page "http://www.dest-unreach.org/socat/")
- (synopsis
- "Open bidirectional communication channels from the command line")
- (description
- "socat is a relay for bidirectional data transfer between two independent
-data channels---files, pipes, devices, sockets, etc. It can create
-\"listening\" sockets, named pipes, and pseudo terminals.
-
-socat can be used, for instance, as TCP port forwarder, as a shell interface
-to UNIX sockets, IPv6 relay, for redirecting TCP oriented programs to a serial
-line, to logically connect serial lines on different computers, or to
-establish a relatively secure environment (su and chroot) for running client
-or server shell scripts with network connections. ")
- (license license:gpl2)))