aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-20 23:40:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-20 23:42:52 +0300
commitae144ec797cebf6f00f80177101020e92e8f2c47 (patch)
tree052407d2791d87b0eaae439e06d25599074635e3 /gnu/packages/shells.scm
parent02406d5c51a8c38136ff8036dd1e62865b8714d1 (diff)
downloadguix-ae144ec797cebf6f00f80177101020e92e8f2c47.tar
guix-ae144ec797cebf6f00f80177101020e92e8f2c47.tar.gz
gnu: oil: Don't hardcode gcc.
* gnu/packages/shells.scm (oil)[arguments]: In custom 'configure phase use cc-for-target instead of hardcoding gcc.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index affc98a6e6..5225e12064 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -829,7 +829,7 @@ Shell (pdksh).")
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
- (setenv "CC" "gcc")
+ (setenv "CC" ,(cc-for-target))
(substitute* "configure"
((" cc ") " $CC "))
(invoke "./configure" (string-append "--prefix=" out)