aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2017-01-22 14:31:54 +0800
committer宋文武 <iyzsong@member.fsf.org>2017-01-22 14:31:54 +0800
commitdf05d80ad09986a6e536144573179ba5a5b649a5 (patch)
tree5edf524224788a24d60fb2d826520faf2f6e182b /gnu/packages/sdl.scm
parentaf7caada4022974dbf5bdf64ede337cfdc5dc932 (diff)
downloadguix-df05d80ad09986a6e536144573179ba5a5b649a5.tar
guix-df05d80ad09986a6e536144573179ba5a5b649a5.tar.gz
gnu: Add guile-sdl2.
* gnu/packages/sdl.scm (guile-sdl2): New variable.
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm42
1 files changed, 41 insertions, 1 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index cb0af1ceed..5103aeed6c 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015, 2017 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2015, 2017 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
@@ -425,3 +425,43 @@ Layer (SDL). With them, Guile programmers can have easy access to graphics,
sound and device input (keyboards, joysticks, mice, etc.).")
(home-page "http://gnu.org/s/guile-sdl")
(license gpl3+)))
+
+(define-public guile-sdl2
+ (package
+ (name "guile-sdl2")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://files.dthompson.us/guile-sdl2/guile-sdl2-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0yq9lsl17cdvj77padvpk3jcw2g6g0pck9jrchc7n2767rrc012b"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags '("GUILE_AUTO_COMPILE=0")
+ #:configure-flags
+ (list (string-append "--with-libsdl2-prefix="
+ (assoc-ref %build-inputs "sdl2"))
+ (string-append "--with-libsdl2-image-prefix="
+ (assoc-ref %build-inputs "sdl2-image"))
+ (string-append "--with-libsdl2-ttf-prefix="
+ (assoc-ref %build-inputs "sdl2-ttf"))
+ (string-append "--with-libsdl2-mixer-prefix="
+ (assoc-ref %build-inputs "sdl2-mixer")))))
+ (native-inputs
+ `(("guile" ,guile-2.0)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("sdl2-mixer" ,sdl2-mixer)
+ ("sdl2-ttf" ,sdl2-ttf)))
+ (synopsis "Guile bindings for SDL2")
+ (home-page "https://dthompson.us/projects/guile-sdl2.html")
+ (description
+ "Guile-SDL2 provides Guile Scheme bindings for the SDL2 C shared library.
+The bindings are written in pure Scheme using Guile's foreign function
+interface.")
+ (license lgpl3+)))