aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-10-27 11:55:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-10-27 12:23:03 +0300
commit5d5790ce44667cac4236559caba3516922c99843 (patch)
tree37d9222521354e626b1952e480d9f92f4fcd733c /gnu/packages/sdl.scm
parent483b7ce7ae2186a6c0fb4591b4d9308a5da648d8 (diff)
downloadguix-5d5790ce44667cac4236559caba3516922c99843.tar
guix-5d5790ce44667cac4236559caba3516922c99843.tar.gz
gnu: Use 'https' for libsdl urls.
* gnu/packages/sdl.scm (sdl, sdl2, sdl-image, sdl-mixer, sdl-net) (sdl-ttf, sdl2-image, sdl2-ttf)[source]: Use https. [home-page]: Use https.
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 161689bf24..aba57c159a 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,7 +48,7 @@
(source (origin
(method url-fetch)
(uri
- (string-append "http://libsdl.org/release/SDL-"
+ (string-append "https://libsdl.org/release/SDL-"
version ".tar.gz"))
(sha256
(base32
@@ -81,7 +82,7 @@
(description "Simple DirectMedia Layer is a cross-platform development
library designed to provide low level access to audio, keyboard, mouse,
joystick, and graphics hardware.")
- (home-page "http://libsdl.org/")
+ (home-page "https://libsdl.org/")
(license lgpl2.1)))
(define-public sdl2
@@ -91,7 +92,7 @@ joystick, and graphics hardware.")
(source (origin
(method url-fetch)
(uri
- (string-append "http://libsdl.org/release/SDL2-"
+ (string-append "https://libsdl.org/release/SDL2-"
version ".tar.gz"))
(sha256
(base32
@@ -154,7 +155,7 @@ other supporting functions for SDL.")
(source (origin
(method url-fetch)
(uri
- (string-append "http://www.libsdl.org/projects/SDL_image/release/SDL_image-"
+ (string-append "https://www.libsdl.org/projects/SDL_image/release/SDL_image-"
version ".tar.gz"))
(sha256
(base32
@@ -180,7 +181,7 @@ other supporting functions for SDL.")
(description "SDL_image is an image file loading library for SDL that
supports the following formats: BMP, GIF, JPEG, LBM, PCX, PNG, PNM, TGA, TIFF,
WEBP, XCF, XPM, and XV.")
- (home-page "http://www.libsdl.org/projects/SDL_image/")
+ (home-page "https://www.libsdl.org/projects/SDL_image/")
(license zlib)))
(define-public sdl-mixer
@@ -190,7 +191,7 @@ WEBP, XCF, XPM, and XV.")
(source (origin
(method url-fetch)
(uri
- (string-append "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-"
+ (string-append "https://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-"
version ".tar.gz"))
(sha256
(base32
@@ -218,7 +219,7 @@ WEBP, XCF, XPM, and XV.")
It supports any number of simultaneously playing channels of 16 bit stereo
audio, plus a single channel of music. Supported format include FLAC, MOD,
MIDI, Ogg Vorbis, and MP3.")
- (home-page "http://www.libsdl.org/projects/SDL_mixer/")
+ (home-page "https://www.libsdl.org/projects/SDL_mixer/")
(license zlib)))
(define-public sdl-net
@@ -228,7 +229,7 @@ MIDI, Ogg Vorbis, and MP3.")
(source (origin
(method url-fetch)
(uri
- (string-append "http://www.libsdl.org/projects/SDL_net/release/SDL_net-"
+ (string-append "https://www.libsdl.org/projects/SDL_net/release/SDL_net-"
version ".tar.gz"))
(sha256
(base32
@@ -239,7 +240,7 @@ MIDI, Ogg Vorbis, and MP3.")
(synopsis "SDL networking library")
(description "SDL_net is a small, cross-platform networking library for
SDL.")
- (home-page "http://www.libsdl.org/projects/SDL_net/")
+ (home-page "https://www.libsdl.org/projects/SDL_net/")
(license zlib)))
(define-public sdl-ttf
@@ -249,7 +250,7 @@ SDL.")
(source (origin
(method url-fetch)
(uri
- (string-append "http://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-"
+ (string-append "https://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-"
version ".tar.gz"))
(sha256
(base32
@@ -261,7 +262,7 @@ SDL.")
(native-inputs `(("pkg-config" ,pkg-config)))
(synopsis "SDL TrueType font library")
(description "SDL_ttf is a TrueType font rendering library for SDL.")
- (home-page "http://www.libsdl.org/projects/SDL_ttf/")
+ (home-page "https://www.libsdl.org/projects/SDL_ttf/")
(license zlib)))
(define* (sdl-union #:optional (packages (list sdl sdl-gfx sdl-net sdl-ttf
@@ -308,7 +309,7 @@ directory.")
(source (origin
(method url-fetch)
(uri
- (string-append "http://www.libsdl.org/projects/SDL_image/release/SDL2_image-"
+ (string-append "https://www.libsdl.org/projects/SDL_image/release/SDL2_image-"
version ".tar.gz"))
(sha256
(base32
@@ -342,7 +343,7 @@ directory.")
(source (origin
(method url-fetch)
(uri
- (string-append "http://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-"
+ (string-append "https://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-"
version ".tar.gz"))
(modules '((guix build utils)))
(snippet