aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-11-05 12:01:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-05 18:14:19 +0100
commit39f2433c39b3cb6d1e4c0f04e8b735c181d6feac (patch)
tree3b8b804ad02216ec2207ec775b20a944cc00f61a /gnu/packages/sdl.scm
parent7c5cc400977df8d394cd0aebd0465f94313a0d91 (diff)
downloadguix-39f2433c39b3cb6d1e4c0f04e8b735c181d6feac.tar
guix-39f2433c39b3cb6d1e4c0f04e8b735c181d6feac.tar.gz
gnu: sdl2: Update to 2.0.7 and enable Wayland backend.
* gnu/packages/sdl.scm (sdl2): Update to 2.0.7. [inputs]: Add wayland, wayland-protocols, libxkbcommon. [arguments]: Add '--disable-wayland-shared' to #:configure-flags. Co-authored-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index d3edac14ff..e4e0fdb779 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015, 2017 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,11 +29,13 @@
#:use-module ((guix licenses) #:hide (freetype))
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (gnu packages audio)
#:use-module (gnu packages fcitx)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages guile)
#:use-module (gnu packages ibus)
@@ -42,6 +45,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xorg)
#:export (sdl-union))
@@ -94,7 +98,7 @@ joystick, and graphics hardware.")
(define-public sdl2
(package (inherit sdl)
(name "sdl2")
- (version "2.0.5")
+ (version "2.0.7")
(source (origin
(method url-fetch)
(uri
@@ -102,7 +106,12 @@ joystick, and graphics hardware.")
version ".tar.gz"))
(sha256
(base32
- "11c75qj1qxmx67iwkvf9z4x69phk301pdn86zzr6jncnap7kh824"))))
+ "0pjdpxla5kh1w1b0shxrx97a116vyy31njxi0jhyvqhk8d6cfdgf"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments sdl)
+ ((#:configure-flags flags)
+ `(append '("--disable-wayland-shared")
+ ,flags))))
(inputs
;; SDL2 needs to be built with ibus support otherwise some systems
;; experience a bug where input events are doubled.
@@ -111,7 +120,10 @@ joystick, and graphics hardware.")
(append `(("dbus" ,dbus)
("fcitx" ,fcitx) ; helps with CJK input
("glib" ,glib)
- ("ibus" ,ibus))
+ ("ibus" ,ibus)
+ ("libxkbcommon", libxkbcommon)
+ ("wayland", wayland)
+ ("wayland-protocols", wayland-protocols))
(package-inputs sdl)))
(license bsd-3)))