aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sdl.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2017-10-06 06:26:10 +0300
committerLudovic Courtès <ludo@gnu.org>2017-10-07 23:01:52 +0200
commit3803331803dc954903112fbcef0d00c918cd0410 (patch)
tree3cb03efc72c5e066529505403ce84cc71d61c0f4 /gnu/packages/sdl.scm
parent06ebba151b336000e158549515ca569d7b795b04 (diff)
downloadguix-3803331803dc954903112fbcef0d00c918cd0410.tar
guix-3803331803dc954903112fbcef0d00c918cd0410.tar.gz
gnu: sdl: Add debug output.
* gnu/packages/sdl.scm (sdl, sdl-gfx, sdl-image, sdl-mixer, sdl-net, sdl-ttf): Add debug output. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/sdl.scm')
-rw-r--r--gnu/packages/sdl.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index af598ecb46..fa126afd92 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -83,6 +83,7 @@
("glu" ,glu)
("alsa-lib" ,alsa-lib)
("pulseaudio" ,pulseaudio)))
+ (outputs '("out" "debug"))
(synopsis "Cross platform game development library")
(description "Simple DirectMedia Layer is a cross-platform development
library designed to provide low level access to audio, keyboard, mouse,
@@ -157,6 +158,7 @@ system, such as sound redirection over the network.")
(base32
"0ijljhs0v99dj6y27hc10z6qchyp8gdp4199y6jzngy6dzxlzsvw"))))
(build-system gnu-build-system)
+ (outputs '("out" "debug"))
(arguments
`(,@(if (any (cute string-prefix? <> (or (%current-system)
(%current-target-system)))
@@ -184,6 +186,7 @@ other supporting functions for SDL.")
(base32
"16an9slbb8ci7d89wakkmyfvp7c0cval8xw4hkg0842nhhlp540b"))))
(build-system gnu-build-system)
+ (outputs '("out" "debug"))
(arguments
;; Explicitly link against shared libraries instead of dlopening them.
'(#:configure-flags '("--disable-jpg-shared"
@@ -220,6 +223,7 @@ WEBP, XCF, XPM, and XV.")
(base32
"0alrhqgm40p4c92s26mimg9cm1y7rzr6m0p49687jxd9g6130i0n"))))
(build-system gnu-build-system)
+ (outputs '("out" "debug"))
;; no check target
;; use libmad instead of smpeg
;; explicitly link against shared libraries instead of dlopening them
@@ -260,6 +264,7 @@ MIDI, Ogg Vorbis, and MP3.")
(build-system gnu-build-system)
(propagated-inputs `(("sdl" ,sdl)))
(native-inputs `(("pkg-config" ,pkg-config)))
+ (outputs '("out" "debug"))
(synopsis "SDL networking library")
(description "SDL_net is a small, cross-platform networking library for
SDL.")
@@ -283,6 +288,7 @@ SDL.")
(inputs `(("freetype" ,freetype)
("mesa" ,mesa)))
(native-inputs `(("pkg-config" ,pkg-config)))
+ (outputs '("out" "debug"))
(synopsis "SDL TrueType font library")
(description "SDL_ttf is a TrueType font rendering library for SDL.")
(home-page "https://www.libsdl.org/projects/SDL_ttf/")