aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-01-03 07:52:24 -0500
committerKei Kebreau <kei@openmailbox.org>2017-01-03 08:34:54 -0500
commitb9b6db45e84a7c9677f1b69040efadd0665139bb (patch)
tree0214a54abf030c4c7fa93e04d704a5ac6c36fbb6 /gnu/packages/scheme.scm
parentd338237d8c2408e0cd13ecfeb303e327ff7e3d9b (diff)
downloadguix-b9b6db45e84a7c9677f1b69040efadd0665139bb.tar
guix-b9b6db45e84a7c9677f1b69040efadd0665139bb.tar.gz
gnu: chicken: Update to 4.11.1.
* gnu/packages/scheme.scm (chicken): Update to 4.11.1.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm27
1 files changed, 11 insertions, 16 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 78f387faf0..08bb89cefb 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -323,20 +323,22 @@ mashups, office (web agendas, mail clients, ...), etc.")
(define-public chicken
(package
(name "chicken")
- (version "4.11.0")
+ (version "4.11.1")
(source (origin
- (method url-fetch)
- (uri (string-append "http://code.call-cc.org/releases/"
- version "/chicken-" version ".tar.gz"))
- (sha256
- (base32
- "12ddyiikqknpr8h6llsxbg2fz75xnayvcnsvr1cwv8xnjn7jpp73"))))
+ (method url-fetch)
+ (uri (string-append "http://code.call-cc.org/releases/"
+ version "/chicken-" version ".tar.gz"))
+ (uri (string-append "http://code.call-cc.org/dev-snapshots/"
+ "2016/09/12/chicken-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1rwymbbmnwdyhdzilv9w75an989xw9kjf3x52iqdng3nphpflcga"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
(guix build utils)
(srfi srfi-1))
-
+
;; No `configure' script; run "make check" after "make install" as
;; prescribed by README.
#:phases
@@ -344,14 +346,7 @@ mashups, office (web agendas, mail clients, ...), etc.")
(delete 'configure)
(delete 'check)
(add-after 'install 'check
- (assoc-ref %standard-phases 'check))
- (add-after 'unpack 'disable-broken-tests
- (lambda _
- ;; The port tests fail with this error:
- ;; Error: (line 294) invalid escape-sequence '\x o'
- (substitute* "tests/runtests.sh"
- (("\\$interpret -s port-tests\\.scm") ""))
- #t)))
+ (assoc-ref %standard-phases 'check)))
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list "PLATFORM=linux"