aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 16:39:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-27 12:46:30 +0200
commit2e14ca198230878405a00d4351e5424a7b964a22 (patch)
treef6c4f1caabf3cc5b2d78f904b3f8016738281fd1 /gnu/packages/scheme.scm
parentb69819d8c25ac0e2989b54e998eaa63fa1ce80e0 (diff)
downloadguix-2e14ca198230878405a00d4351e5424a7b964a22.tar
guix-2e14ca198230878405a00d4351e5424a7b964a22.tar.gz
gnu: slib: Return #t from phases.
* gnu/packages/scheme.scm (slib)[arguments]: Substitute INVOKE for SYSTEM*. Return #t rather than undefined from phases.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 4d5c835454..db39632f0c 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -882,12 +882,13 @@ regular-expression notation.")
(add-after 'install 'remove-bin-share
(lambda* (#:key inputs outputs #:allow-other-keys)
(delete-file-recursively
- (string-append (assoc-ref outputs "out") "/bin"))))
+ (string-append (assoc-ref outputs "out") "/bin"))
+ #t))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
- (zero? (system* "./configure"
- (string-append "--prefix="
- (assoc-ref outputs "out")))))))))
+ (invoke "./configure"
+ (string-append "--prefix="
+ (assoc-ref outputs "out"))))))))
(native-inputs `(("unzip" ,unzip)
("texinfo" ,texinfo)))
(home-page "http://people.csail.mit.edu/jaffer/SLIB.html")