aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-15 07:29:59 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-15 14:58:32 +0100
commitcf52c9255d00323f4b1f11a0279aa28e0bfce624 (patch)
tree4d8c333a20706b6072e18d14c80b59394069c352 /gnu/packages/samba.scm
parent33fa13eac196517be9bdc615844a29ca4d8e7a83 (diff)
downloadguix-cf52c9255d00323f4b1f11a0279aa28e0bfce624.tar
guix-cf52c9255d00323f4b1f11a0279aa28e0bfce624.tar.gz
gnu: iniparser: Use #:make-flags.
* gnu/packages/samba.scm (iniparser)[arguments]: Use #:make-flags to set ‘CC’ instead of patching the Makefile. Remove fruitless SYMLINK call.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 7e00ca3d05..88c2df6675 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -104,18 +104,19 @@ the Linux kernel CIFS client.")
"1flj7srvh2hp9ls96qz922bklyhw7f27mmn23b16839zpdjddfz0"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:make-flags
+ (list "CC=gcc")
+ #:phases
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(substitute* '("Makefile" "test/Makefile")
(("/usr/lib")
- (string-append (assoc-ref outputs "out") "/lib"))
- (("\\?= gcc") "= gcc"))))
+ (string-append (assoc-ref outputs "out") "/lib")))))
(replace 'build
- (lambda _
- (and (zero? (system* "make" "libiniparser.so"))
- (symlink "libiniparser.so.0" "libiniparser.so"))))
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "libiniparser.so"
+ make-flags)))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))