aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-23 21:30:49 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-24 10:59:59 +0100
commit8420d1762be2af25ebf9f7285eb35f6a78d6b7c5 (patch)
treed35296becfe385ec904cc1cbadc368c4b620ca4f /gnu/packages/sagemath.scm
parent340df4885fe6ae523d311e2fc00119798d9a7571 (diff)
downloadguix-8420d1762be2af25ebf9f7285eb35f6a78d6b7c5.tar
guix-8420d1762be2af25ebf9f7285eb35f6a78d6b7c5.tar.gz
gnu: packages/sagemath: Sort alphabetically.
* gnu/packages/sagemath.scm: (libbraiding, libhomfly): Sort variables alphabetically. Change-Id: I91c73ba0e11a7542e64a1683942f4b95efb14e14
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm100
1 files changed, 50 insertions, 50 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 6d9d00fe55..3dd220b132 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -106,6 +106,56 @@ function for every found clique.")
(license license:gpl2+)
(home-page "https://users.aalto.fi/~pat/cliquer.html")))
+(define-public libbraiding
+ (package
+ (name "libbraiding")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/miguelmarco/"
+ name))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l68rikfr7k2l547gb3pp3g8cj5zzxwipm79xrb5r8ffj466ydxg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf automake libtool))
+ (synopsis "Computations with braid groups")
+ (description "libbraiding performs computations with braid groups,
+in particular it computes normal forms of group elements.")
+ (license license:gpl2+)
+ (home-page "https://github.com/miguelmarco/libbraiding")))
+
+(define-public libhomfly
+ (package
+ (name "libhomfly")
+ (version "1.02r6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/miguelmarco/"
+ name))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0sv3cwrf9v9sb5a8wbhjmarxvya13ma3j8y8592f9ymxlk5y0ldk"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf automake libtool))
+ (inputs
+ (list libgc))
+ (synopsis "Computation of homfly polynomials of links")
+ (description "libhomfly computes homfly polynomials of links,
+represented as strings.")
+ (license license:public-domain)
+ (home-page "https://github.com/miguelmarco/libhomfly")))
+
(define-public python-cypari2
(package
(name "python-cypari2")
@@ -187,56 +237,6 @@ libraries GMO, MPFR and MPC.")
@item @code{aligned_allocarray}")
(license license:gpl3+)))
-(define-public libbraiding
- (package
- (name "libbraiding")
- (version "1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url (string-append "https://github.com/miguelmarco/"
- name))
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0l68rikfr7k2l547gb3pp3g8cj5zzxwipm79xrb5r8ffj466ydxg"))))
- (build-system gnu-build-system)
- (native-inputs
- (list autoconf automake libtool))
- (synopsis "Computations with braid groups")
- (description "libbraiding performs computations with braid groups,
-in particular it computes normal forms of group elements.")
- (license license:gpl2+)
- (home-page "https://github.com/miguelmarco/libbraiding")))
-
-(define-public libhomfly
- (package
- (name "libhomfly")
- (version "1.02r6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url (string-append "https://github.com/miguelmarco/"
- name))
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0sv3cwrf9v9sb5a8wbhjmarxvya13ma3j8y8592f9ymxlk5y0ldk"))))
- (build-system gnu-build-system)
- (native-inputs
- (list autoconf automake libtool))
- (inputs
- (list libgc))
- (synopsis "Computation of homfly polynomials of links")
- (description "libhomfly computes homfly polynomials of links,
-represented as strings.")
- (license license:public-domain)
- (home-page "https://github.com/miguelmarco/libhomfly")))
-
(define-public python-pplpy
(package
(name "python-pplpy")