aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-01-31 21:01:59 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-02-10 21:54:31 +1000
commitfa73a7c1b3d9b56395152a0284e10171b4fefaed (patch)
tree49a415d7c99f31a0f13dfe85e4969be9a5e01f54 /gnu/packages/rust.scm
parent836cbd9f72fa3e2bcd4102c3db1b6f3c0671ed2f (diff)
downloadguix-fa73a7c1b3d9b56395152a0284e10171b4fefaed.tar
guix-fa73a7c1b3d9b56395152a0284e10171b4fefaed.tar.gz
gnu: rustc: Add native-search-paths.
* gnu/packages/rust.scm (rust)[native-search-paths]: New field. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index ae04530041..fb284102da 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Eric Le Bihan <eric.le.bihan.dev@free.fr>
;;; Copyright © 2016 ng0 <ng0@libertad.pw>
+;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -272,6 +273,8 @@ rustc-bootstrap and cargo-bootstrap packages.")
(wrap-program (string-append out "/bin/rustc")
`("PATH" ":" prefix (,(string-append ld-wrapper "/bin")))
`("LIBRARY_PATH" ":" suffix (,(string-append libc "/lib"))))))))))
+ ;; rustc invokes gcc, so we need to set its search paths accordingly.
+ (native-search-paths (package-native-search-paths gcc))
(synopsis "Compiler for the Rust progamming language")
(description "Rust is a systems programming language that provides memory
safety and thread safety guarantees.")