aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2021-01-04 01:32:12 +0100
committerChristopher Baines <mail@cbaines.net>2021-02-05 19:37:28 +0000
commit45270b1862aaf2e4ae5f9fec00fb4a6dede04196 (patch)
treef1caf33e0a54099c86ec88e06b746b76740f16c7 /gnu/packages/ruby.scm
parent0af8398b50c6ed394032618febeb481c3200d3c0 (diff)
downloadguix-45270b1862aaf2e4ae5f9fec00fb4a6dede04196.tar
guix-45270b1862aaf2e4ae5f9fec00fb4a6dede04196.tar.gz
gnu: Add ruby-ethon.
* gnu/packages/ruby.scm (ruby-ethon): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0e7f6d98f9..2a5d4f0f06 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2348,6 +2348,30 @@ support.")
(home-page "http://www.kuwata-lab.com/erubis/")
(license license:expat)))
+(define-public ruby-ethon
+ (package
+ (name "ruby-ethon")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ethon" version))
+ (sha256
+ (base32
+ "0gggrgkcq839mamx7a8jbnp2h7x2ykfn34ixwskwb0lzx2ak17g9"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; no included tests
+ (inputs
+ `(("curl" ,curl)))
+ (propagated-inputs
+ `(("ruby-ffi" ,ruby-ffi)))
+ (synopsis "Very lightweight @code{libcurl} wrapper")
+ (description
+ "Ethon is a very basic @code{libcurl} wrapper using ffi.")
+ (home-page "https://github.com/typhoeus/ethon")
+ (license license:expat)))
+
(define-public ruby-execjs
(package
(name "ruby-execjs")