aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2021-01-04 01:32:11 +0100
committerChristopher Baines <mail@cbaines.net>2021-02-05 19:37:28 +0000
commit0af8398b50c6ed394032618febeb481c3200d3c0 (patch)
tree7d3d11d0604dff7ddb92e4d71f70beeccab03b13 /gnu/packages/ruby.scm
parentdbe02ce50fb595b32c83770d2c15e80607cd5f5a (diff)
downloadguix-0af8398b50c6ed394032618febeb481c3200d3c0.tar
guix-0af8398b50c6ed394032618febeb481c3200d3c0.tar.gz
gnu: Add ruby-patron.
* gnu/packages/ruby.scm (ruby-patron): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 04d4d2f334..0e7f6d98f9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Holgr Peters <holger.peters@posteo.de>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -49,6 +50,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages dbm)
#:use-module (gnu packages rails)
@@ -1163,6 +1165,31 @@ more.")
(home-page "https://github.com/xwmx/pandoc-ruby")
(license license:expat)))
+(define-public ruby-patron
+ (package
+ (name "ruby-patron")
+ (version "0.13.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "patron" version))
+ (sha256
+ (base32
+ "0523gddx88zql2mq6655k60gy2ac8vybpzkcf90lmd9nx7wl3fi9"))))
+ (build-system ruby-build-system)
+ (inputs
+ `(("curl" ,curl)))
+ (arguments
+ `(#:tests? #f)) ; no included tests
+ (synopsis "Ruby HTTP client library based on @code{libcurl}")
+ (description
+ "Patron is a Ruby HTTP client library based on @code{libcurl}. It does
+not try to expose the full power (read complexity) of @code{libcurl} but
+instead tries to provide a sane API while taking advantage of @code{libcurl}
+under the hood.")
+ (home-page "https://github.com/toland/patron")
+ (license license:expat)))
+
(define-public ruby-slim
(package
(name "ruby-slim")