aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2017-12-27 17:03:08 +0100
committerClément Lassieur <clement@lassieur.org>2017-12-28 07:20:02 +0100
commitf90c25c1c84071d42a652396d290582ceef9b6ed (patch)
tree9d5192520e2bc3bd667d58966ba1e835ce98eebf /gnu/packages/ruby.scm
parent0684f1d6b522b9e543861109ecefa14066b492bd (diff)
downloadguix-f90c25c1c84071d42a652396d290582ceef9b6ed.tar
guix-f90c25c1c84071d42a652396d290582ceef9b6ed.tar.gz
gnu: Add ruby-rubypants.
* gnu/packages/ruby.scm (ruby-rubypants): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 827295cb1c..69dd6a8365 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4467,3 +4467,25 @@ are doing, you can fiddle with every last bit of your email directly.")
more robust and work for non rails projects.")
(home-page "http://github.com/danmayer/code_statistics")
(license license:expat)))
+
+(define-public ruby-rubypants
+ (package
+ (name "ruby-rubypants")
+ (version "0.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rubypants" version))
+ (sha256
+ (base32
+ "0xpqkslan2wkyal2h9qhplkr5d4sdn7q6csigrhnljjpp8j4qfsh"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; need Codecov
+ (synopsis "Port of the smart-quotes library SmartyPants")
+ (description
+ "RubyPants is a Ruby port of the smart-quotes library SmartyPants. The
+original SmartyPants is a web publishing plug-in for Movable Type, Blosxom,
+and BBEdit that easily translates plain ASCII punctuation characters into
+smart typographic punctuation HTML entities.")
+ (home-page "https://github.com/jmcnevin/rubypants")
+ (license license:bsd-2)))