aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-01-08 10:18:41 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-01-08 11:10:28 +1000
commit6499893ef82b85e9ba67b9e086e82644b94a55bb (patch)
treef9c58b7b14b6fbbc0b293370b776e40c960a2516 /gnu/packages/ruby.scm
parent57fe28a082f9ff0a2d318205b4532479a74768b4 (diff)
downloadguix-6499893ef82b85e9ba67b9e086e82644b94a55bb.tar
guix-6499893ef82b85e9ba67b9e086e82644b94a55bb.tar.gz
gnu: ruby-yard: Update to 0.9.6.
* gnu/packages/ruby.scm (ruby-yard): Update to 0.9.6. [source]: Use 'GitHub' source. [arguments]: Run tests without 'Rakefile'. [native-inputs]: Replace 'ruby-rspec-2' with ruby-rspec'. * gnu/packages/patches/ruby-yard-fix-skip-of-markdown-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm66
1 files changed, 31 insertions, 35 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 50dde3f48c..4a2a3c1d31 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3049,44 +3049,40 @@ features such as filtering and fine grained logging.")
(license license:expat)))
(define-public ruby-yard
- ;; Use git reference because gem is >100 commits out of date and the tests
- ;; do not pass with the released gem.
- (let ((commit "d816482a0d4850506c3bcccc9434550c536c28c6"))
- (package
- (name "ruby-yard")
- (version (string-append "0.9.5-1." (string-take commit 8)))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lsegal/yard.git")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1j16c85x22if7y0fzi3c900p9wzkx2riq1y7vsj92a0zvwsxai4i"))
- (patches (search-patches "ruby-yard-fix-skip-of-markdown-tests.patch"))))
- (build-system ruby-build-system)
- (arguments
- `(#:test-target "spec"
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'set-HOME-and-disable-failing-test
- (lambda _
- ;; $HOME needs to be set to somewhere writeable for tests to run
- (setenv "HOME" "/tmp")
- #t)))))
- (native-inputs
- `(("ruby-rspec" ,ruby-rspec-2)
- ("ruby-rack" ,ruby-rack)))
- (synopsis "Documentation generation tool for Ruby")
- (description
- "YARD is a documentation generation tool for the Ruby programming
+ (package
+ (name "ruby-yard")
+ (version "0.9.6")
+ (source
+ (origin
+ (method url-fetch)
+ ;; Tests do not pass if we build from the distributed gem.
+ (uri (string-append "https://github.com/lsegal/yard/archive/v"
+ version "tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0rsz4bghgx7fryzyhlz8wlnd2m9xgyvf1xhrq58mnzfrrfm41bdg"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; $HOME needs to be set to somewhere writeable for tests to run
+ (setenv "HOME" "/tmp")
+ ;; Run tests without using 'rake' to avoid dependencies.
+ (zero? (system* "rspec")))))))
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis "Documentation generation tool for Ruby")
+ (description
+ "YARD is a documentation generation tool for the Ruby programming
language. It enables the user to generate consistent, usable documentation
that can be exported to a number of formats very easily, and also supports
extending for custom Ruby constructs such as custom class level definitions.")
- (home-page "http://yardoc.org")
- (license license:expat))))
+ (home-page "http://yardoc.org")
+ (license license:expat)))
(define-public ruby-clap
(package