aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-14 15:08:10 +0000
committerMarius Bakke <mbakke@fastmail.com>2017-01-14 17:53:05 +0100
commit06116573b5cb5b11cc5760fc248fb47d586ff1ea (patch)
tree334517c65abb9b8f87497be39c06749c4b767e6b /gnu/packages/ruby.scm
parent5713993f3549feb3b4ecb55f486df68ad79d6c66 (diff)
downloadguix-06116573b5cb5b11cc5760fc248fb47d586ff1ea.tar
guix-06116573b5cb5b11cc5760fc248fb47d586ff1ea.tar.gz
gnu: Add ruby-mail.
* gnu/packages/ruby.scm (ruby-mail): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8fb22d0060..fb89238bd9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2014, 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
+;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4198,3 +4199,35 @@ RFC 2617. This enables the use of the digest authentication scheme instead
of the more insecure basic authentication scheme.")
(home-page "http://github.com/drbrain/net-http-digest_auth")
(license license:expat)))
+
+(define-public ruby-mail
+ (package
+ (name "ruby-mail")
+ (version "2.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "mail" version))
+ (sha256
+ (base32
+ "0c9vqfy0na9b5096i5i4qvrvhwamjnmajhgqi3kdsdfl8l6agmkp"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-mime-types" ,ruby-mime-types)))
+ (arguments
+ ;; Tests require extra gems not included in the Gemfile.
+ ;; XXX: Try enabling this for the next version with mini_mime.
+ `(#:tests? #f))
+ (synopsis "Mail library for Ruby")
+ (description
+ "Mail is an internet library for Ruby that is designed to handle email
+generation, parsing and sending. The purpose of this library is to provide
+a single point of access to handle all email functions, including sending
+and receiving emails. All network type actions are done through proxy
+methods to @code{Net::SMTP}, @code{Net::POP3} etc.
+
+Mail has been designed with a very simple object oriented system that
+really opens up the email messages you are parsing, if you know what you
+are doing, you can fiddle with every last bit of your email directly.")
+ (home-page "https://github.com/mikel/mail")
+ (license license:expat)))