aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/racket.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-08-27 14:55:54 -0400
committerLudovic Courtès <ludo@gnu.org>2022-09-04 23:10:12 +0200
commited24d6b46cc0f4ff32c3f285e9bb42a319c6f8ca (patch)
treeccb6a481791b1cee81e25b6a59ac0d60f581bb05 /gnu/packages/racket.scm
parent64a27e1678930307de49e29c4a55bd3b5de79857 (diff)
downloadguix-ed24d6b46cc0f4ff32c3f285e9bb42a319c6f8ca.tar
guix-ed24d6b46cc0f4ff32c3f285e9bb42a319c6f8ca.tar.gz
gnu: racket: Use Racket CS on all systems.
This patch uses the 'pbarch' support added to 'racket-vm-cs' to make it the default Racket VM implementation on all systems. * gnu/packages/racket.scm (racket-vm-for-system): Remove. (racket-minimal, racket)[inputs]: Replace '(racket-vm-for-system)' with 'racket-vm-cs'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/racket.scm')
-rw-r--r--gnu/packages/racket.scm20
1 files changed, 4 insertions, 16 deletions
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index 74052d47eb..32ea866bff 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -128,10 +128,9 @@
;; This file defines the packages 'racket-vm-cgc', 'racket-vm-bc', and
;; 'racket-vm-cs'. All three are in-place builds of 'racket/src/' and
;; 'racket/collects/' and are installed to 'opt/racket-vm/' in the store
-;; output. The function 'racket-vm-for-system' returns the recomended Racket
-;; VM package for a given system.
+;; output.
;;
-;; We then define the packages 'racket-minimal' and
+;; Using 'racket-vm-cs', we then define the packages 'racket-minimal' and
;; 'racket'. These use Racket's support for ``layered installations'', which
;; allow an immutable base layer to be extended with additional packages.
;; They use the layer configuration directly provide ready-to-install FHS-like
@@ -192,17 +191,6 @@
;;
;; CODE:
-(define* (racket-vm-for-system #:optional
- (system (or (%current-target-system)
- (%current-system))))
- "Return 'racket-vm-cs' if we are able to build it for SYSTEM; 'racket-vm-bc'
-otherwise."
- ;; Once we figure out the issues in https://racket.discourse.group/t/950,
- ;; we can use 'racket-vm-cs' everywhere.
- (if (racket-cs-native-supported-system? system)
- racket-vm-cs
- racket-vm-bc))
-
(define %racket-version "8.6") ; Remember to update chez-scheme-for-racket!
(define %zuo-version "1.0") ; defined in racket/src/zuo/zuo.c
(define %racket-commit
@@ -566,7 +554,7 @@ used to build the name of the resulting store item."
(inputs
(list openssl
sqlite
- (racket-vm-for-system)
+ racket-vm-cs
(racket-packages-origin
"base" %racket-origin
'(("base" "pkgs/base")
@@ -684,7 +672,7 @@ DrRacket IDE, are not included.")
unixodbc
libedit ;; TODO reconsider in light of expeditor and readline-gpl
racket-minimal ;; <-- TODO non-tethered layer
- (racket-vm-for-system)
+ racket-vm-cs
(simple-racket-origin
"2d" (base32 "0fb5v6058ls08xw3zbmqyr2ym0psm119gl9ffgmhm9w8rs9i4dq7")
'("2d" "2d-doc" "2d-lib"))