aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-15 20:08:10 +0200
committerMarius Bakke <marius@gnu.org>2020-07-15 20:08:10 +0200
commitdec0217f6e21a2f48328aaff5448dcf2f4fea7d9 (patch)
tree684f37a5f3c6033633f884d06c27a59dbc727b83 /gnu/packages/qt.scm
parentb514478cb9205ef04194dbe4235765abd0930da9 (diff)
downloadguix-dec0217f6e21a2f48328aaff5448dcf2f4fea7d9.tar
guix-dec0217f6e21a2f48328aaff5448dcf2f4fea7d9.tar.gz
gnu: python-shiboken-2, python-pyside-2: Update to 5.14.2.3.
* gnu/packages/patches/qtbase-absolute-runpath.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/qt.scm (qtbase/next): New variable. * gnu/packages/qt.scm (python-shiboken-2): Update to 5.14.2.3. [source](uri): Adjust for tarball rename. [inputs]: Use the default CLANG-TOOLCHAIN. (python-pyside-2)[inputs]: Likewise. (python-pyside-2-tools)[inputs]: Change from QTBASE to QTBASE/NEXT.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm24
1 files changed, 18 insertions, 6 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7e9036c4b4..0cb36427a0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -596,6 +596,18 @@ developers using C++ or QML, a CSS & JavaScript like language.")
;; qt used to refer to the monolithic Qt 5.x package
(define-deprecated qt qtbase)
+;; This variable is required by 'python-pyside-2-tools', which copies some
+;; qtbase executables that fail to run because RUNPATH refers to the
+;; wrong $ORIGIN. TODO: Merge with qtbase in the next rebuild cycle.
+(define qtbase/next
+ (package
+ (inherit qtbase)
+ (source
+ (origin
+ (inherit (package-source qtbase))
+ (patches (append (origin-patches (package-source qtbase))
+ (search-patches "qtbase-absolute-runpath.patch")))))))
+
(define-public qtsvg
(package (inherit qtbase)
(name "qtsvg")
@@ -2566,19 +2578,19 @@ color-related widgets.")
(define-public python-shiboken-2
(package
(name "python-shiboken-2")
- (version "5.12.6")
+ (version "5.14.2.3")
(source (origin
(method url-fetch)
(uri (string-append "https://download.qt.io/official_releases"
"/QtForPython/pyside2/PySide2-" version
- "-src/pyside-setup-everywhere-src-"
+ "-src/pyside-setup-opensource-src-"
version ".tar.xz"))
(sha256
(base32
- "1n45l6xxyxs6cfp2l4rp8qs1c2fyfwyrdxa4qcpwfsqsi51rydsk"))))
+ "08lhqm0n3fjqpblcx9rshsp8g3bvf7yzbai5q99bly2wa04y6b83"))))
(build-system cmake-build-system)
(inputs
- `(("clang-toolchain" ,clang-toolchain-6)
+ `(("clang-toolchain" ,clang-toolchain)
("libxml2" ,libxml2)
("libxslt" ,libxslt)
("python-wrapper" ,python-wrapper)
@@ -2631,7 +2643,7 @@ color-related widgets.")
(inputs
`(("libxml2" ,libxml2)
("libxslt" ,libxslt)
- ("clang-toolchain" ,clang-toolchain-6)
+ ("clang-toolchain" ,clang-toolchain)
("qtbase" ,qtbase)
("qtdatavis3d" ,qtdatavis3d)
("qtlocation" ,qtlocation)
@@ -2699,7 +2711,7 @@ generate Python bindings for your C or C++ code.")
(inputs
`(("python-pyside-2" ,python-pyside-2)
("python-shiboken-2" ,python-shiboken-2)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase/next)))
(native-inputs
`(("python" ,python-wrapper)))
(arguments