aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-21 09:04:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-10-28 09:51:25 +0200
commitd28af1991ae0a99e660ad1b82ac955556d3a9382 (patch)
tree950c54c2c503d26f95d12c153e19eb3608cd1fd6 /gnu/packages/qt.scm
parent7930cfc98923eda64ec4a37d56b19f96f86f5f59 (diff)
downloadguix-d28af1991ae0a99e660ad1b82ac955556d3a9382.tar
guix-d28af1991ae0a99e660ad1b82ac955556d3a9382.tar.gz
gnu: qt: Use system sqlite.
* gnu/packages/databases.scm (sqlite-with-column-metadata): New variable. * gnu/packages/qt.scm (qt, qtbase)[source]: Remove bundled sqlite. [inputs]: Add sqlite-with-column-metadata. [arguments]: Add configure-flag to use system sqlite.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 05713e8ef1..dffa8b5cf0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -135,7 +135,7 @@ system, and the core design of Django is reused in Grantlee.")
(lambda (dir)
(delete-file-recursively (string-append "qtbase/src/3rdparty/" dir)))
(list "double-conversion" "freetype" "harfbuzz-ng"
- "libpng" "libjpeg" "pcre2" "xcb"
+ "libpng" "libjpeg" "pcre2" "sqlite" "xcb"
"xkbcommon" "zlib"))
(for-each
(lambda (dir)
@@ -206,7 +206,7 @@ system, and the core design of Django is reused in Grantlee.")
("postgresql" ,postgresql)
("pulseaudio" ,pulseaudio)
("pcre2" ,pcre2)
- ;("sqlite" ,sqlite)
+ ("sqlite" ,sqlite-with-column-metadata)
("udev" ,eudev)
("unixodbc" ,unixodbc)
("wayland" ,wayland)
@@ -273,7 +273,7 @@ system, and the core design of Django is reused in Grantlee.")
"-no-compile-examples"
;; Most "-system-..." are automatic, but some use
;; the bundled copy by default.
- ;"-system-sqlite"
+ "-system-sqlite"
"-system-harfbuzz"
"-system-pcre"
;; explicitly link with openssl instead of dlopening it
@@ -503,7 +503,7 @@ system, and the core design of Django is reused in Grantlee.")
(lambda (dir)
(delete-file-recursively (string-append "src/3rdparty/" dir)))
(list "double-conversion" "freetype" "harfbuzz-ng"
- "libpng" "libjpeg" "pcre2" "xcb"
+ "libpng" "libjpeg" "pcre2" "sqlite" "xcb"
"xkbcommon" "zlib"))
#t))))
(build-system gnu-build-system)
@@ -545,7 +545,7 @@ system, and the core design of Django is reused in Grantlee.")
("pcre2" ,pcre2)
("postgresql" ,postgresql)
("pulseaudio" ,pulseaudio)
- ;("sqlite" ,sqlite)
+ ("sqlite" ,sqlite-with-column-metadata)
("unixodbc" ,unixodbc)
("xcb-util" ,xcb-util)
("xcb-util-image" ,xcb-util-image)
@@ -616,10 +616,7 @@ system, and the core design of Django is reused in Grantlee.")
"-no-compile-examples"
;; Most "-system-..." are automatic, but some use
;; the bundled copy by default.
- ;; System sqlite fails on 5.10+
- ;;.obj/qsql_sqlite.o: In function `QSQLiteResultPrivate::initColumns(bool)':
- ;;qsql_sqlite.cpp:(.text+0x190c): undefined reference to `sqlite3_column_table_name16'
- ;"-system-sqlite"
+ "-system-sqlite"
"-system-harfbuzz"
"-system-pcre"
;; explicitly link with openssl instead of dlopening it