aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2018-03-31 23:19:12 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-04 14:39:39 +0200
commit95f3b626d7117571df9a9bd48dd5109213395215 (patch)
treeac2d9455f6a89c563fe00a4097fb7c3097563122 /gnu/packages/python.scm
parentc3581ef968c7bcdd992b1960a19e3a4bcfa26280 (diff)
downloadguix-95f3b626d7117571df9a9bd48dd5109213395215.tar
guix-95f3b626d7117571df9a9bd48dd5109213395215.tar.gz
gnu: Add python-empy.
* gnu/packages/python.scm (python-empy): New variable. (python2-empy): Use 'package-with-python-2'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9e038ef4fb..e6ae8f433b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2018 Ethan R. Jones <ethanrjones97@gmail.com
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
+;;; Copyright © 2018 Mathieu Lirzin <mthl@gnu.org>
;;; This file is part of GNU Guix.
;;;
@@ -1304,9 +1305,9 @@ applications. dogtail scripts are written in Python and executed like any
other Python program.")
(license license:gpl2+)))
-(define-public python2-empy
+(define-public python-empy
(package
- (name "python2-empy")
+ (name "python-empy")
(version "3.3")
(source (origin
(method url-fetch)
@@ -1317,12 +1318,7 @@ other Python program.")
"01g8mmkfnvjdmlhsihwyx56lrg7r5m5d2fg6mnxsvy6g0dnl69f6"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (zero? (system* "./test.sh")))))))
+ `(#:tests? #f)) ;python2 only
(home-page "http://www.alcyone.com/software/empy/")
(synopsis "Templating system for Python")
(description
@@ -1339,6 +1335,9 @@ system is highly configurable via command line options and embedded
commands.")
(license license:lgpl2.1+)))
+(define-public python2-empy
+ (package-with-python2 python-empy))
+
(define-public python2-element-tree
(package
(name "python2-element-tree")