aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorVijayalakshmi <vijimay12@gmail.com>2018-03-19 22:20:25 +0530
committerRicardo Wurmus <rekado@elephly.net>2018-03-20 19:47:37 +0100
commit385e8614ef394a30966bbc992b6ece929665f1bc (patch)
treed8b6404fe706edc706eeaad4ca27bf07bc847a75 /gnu/packages/python.scm
parent8c4bd04c86cc43252b2f9473f398717970b77234 (diff)
downloadguix-385e8614ef394a30966bbc992b6ece929665f1bc.tar
guix-385e8614ef394a30966bbc992b6ece929665f1bc.tar.gz
gnu: Add python-logwrap.
* gnu/packages/python.scm (python-logwrap): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b6fb445b44..3811233272 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -47,7 +47,8 @@
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;; Copyright © 2018 Ethan R. Jones <ethanrjones97@gmail.com
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
-;;;
+;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
+
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
@@ -524,6 +525,33 @@ pidof, tty, taskset, pmap.")
planar geometric objects. It is based on the @code{GEOS} library.")
(license license:bsd-3)))
+(define-public python-logwrap
+ (package
+ (name "python-logwrap")
+ (version "3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "logwrap" version ".zip"))
+ (sha256
+ (base32
+ "1d2k0hvpbi51vl410y8fbs5m0nxnlh2k7gr2nrh3k81ibhzscsra"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-typing" ,python-typing)))
+ (native-inputs
+ `(("unzip" ,unzip)
+ ("python-cython" ,python-cython)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/penguinolog/logwrap")
+ (synopsis "Decorator for logging function arguments")
+ (description "This package provides a decorator to log function arguments
+and function call return values in a human-readable way.")
+ (license license:asl2.0)))
+
(define-public python2-shapely
(package-with-python2 python-shapely))